Matek F405-miniTE + Holybro M9N GPS module. GPS 1: detected as u-blox at 230400 baud - BUT no FIX!

I am unable to get GPS fix in the Holybro M9N and F405-miniTE setup. attached the parameter file

f405miniTE.param (18.6 KB)

  1. swapped RX TX PIN. - NO USE - when Swapped it dindn’t even showed GP1 detected
  2. Connected to tx5 and rx5 PIN - Serial 3.
    3.Changed BAUD rate to 230, but no use.

any help

No Fix means the GPS is detected and working. It just hasn’t got enough position information yet. Are you inside or out? Does the GPS have a clear view of the sky?

i am outside, and clear to sky

Is there an antenna connected?

other than GPS antenna?
no only M9N unit is connected to flight contoller

Indeed. I’m asking if there is a GPS antenna either built in or connected. What you are showing is a valid configuration with no reception.

Let it sit for 15 minutes, powered on and see if anything changes.

Okay, yes GPS antenna built in!

Guys, Problem solved. looks like a faulty GPS unit. soldered a new M9N holybro GPS and it worked like a charm.

Thanks for the help guys.