Marvelmind no longer working with ArduRover?

The Marvelmind ultrasonic beacons work great with the latest ArduCopter (3.5) but with ArduRover 3.2, I get a “No GPS” with all the same settings on Pixhawk. Anybody know why ArduRover no longer works with Marvelmind? I’m following all the regular instructions, including using EKF 3.

Make sure the connections are OK.
It should work, I am the author of the device driver. but I have no time to test now. sorry.

With the same cable and and the same settings it works fine with ArduCopter. Just not with the latest ArduRover

@rmackay9 any ideas ?

I found the problem. The instructions said to set GPS Type to None, but it should actually be set to Type 5 (NMEA)

Now that I’ve got past that, I’m now encountering the “mode change failed” error and can’t get it into auto. Any idea how to get the AHRS to stop complaining about GPS divergence with beacons? (I’ve already tried the “set EKF home to here” button in Mission Planner)

I’ve tried everything. Latest ArduRover 3.2.1, aligned beacons to the compass, tried both EKF 2 and EKF3, tried both GPS Type None and GPS Type 5 (NEMA), etc.

Just can’t get past the AHRS errors and mode change failures.

Thinking about downgrading way back to ArduRover 2 to see if that works. [Update: it didn’t]

I tried changing GPS type to 5, with my POZYX controlled rover. While I don’t get the mode change failure, I do get EK3 waiting for GPS config data error.

Bill, would you mind sharing your config file? The documentation (both Marvelmind’s and the Pozyx ones) have a series of contradictory suggestions (from the UART settings to which EKF settings to use), and it sounds like yours works. Does yours work with GPS Type 0 (none)?

Also, I got rid of the “EKF3 waiting for GPS config data” by just disabling EKF3 and using EKF2 instead. But now the rover doesn’t seem to move on the map when I move it physically. Sigh.

Hi Chris,

Below is my config file. You may find some of the steering and navigation parameters way out of the norm. First, my patented robot is 4 feet wide x 1-1/2 feet long. Secondly I have no clue what I’m doing even after reading the tuning guides. So if there are any tuning consultants who live in the S.F. bay area, please feel free to say hello.

POZYX_Sys_(7) Good tuning.param (12.3 KB)


1 Like

Excellent. I’m pretty good at tuning and live in the Bay Area, so happy to help. We’re in Berkeley. You?

Moraga! I could definitely use the help. How do we get in touch without given out our emails over this system.


You’re ten minutes away from us! I’m

I just ordered the MM system. I’ll let you know how it works. I’m actually sorta hoping to discover how to bypass the Pixhawk/MP system since my robot will be operating in a defined space rather than on the street or other GPS-able area.


PS I just got an email from the Marvelmind customer support with regards to this post…

Yes, I have seen the post. You see, the issue is rather in ArduRover or ArduRover/Marvelmind than in PixHawk. We do have good connection with PixHawk. But there may be some settings in ArduRover different from ArduPilot that causes the difference. Since we don’t actively test with ArduPilot, it is not easy for us to comment. I hope that somebody on the forum may help

I echo that hope :grinning:

OK… following zlite’s recommendations on the MM forum, I’ve got the MM working with the Pixhawk. In addition I’ve switched over to K3 from K2 and it also seems to work.

The MM system is pretty nice. With battery operated beacons and a nice “dashboard” that I’ve just started to explore, it does the job!

Support is not too slow and they seem to want to continue to make their system better. MM support says that MM beacons with IP67 is within weeks of being available.

So right now Marvelmind is my choice over POZYX for precision localization.


1 Like


Thanks for the feedback. I don’t have an MM system but I would like to get a wiki page created to help people with the setup… perhaps I’ll make a skeleton page and then others can help fill in the details?

Happy to help. BTW it was @Chris_Anderson*** who introduced the Marvelmind (MM) system to me. The MM people do have some instructions for interfacing with, among others, a Pixhawk copter on But by their own admission, they do not have much experience with Pixhawk rovers.

***Yesterday we played around with his MM system while at a Hack-a-robot meetup in Oakland. 100 or more folks of all ages with very cool rovers that use vision only for guidance raced each other on a taped-up-track inside the old American Steel building.

Good stuff. I’ll ping here again when the skeleton page is created.

By the way, i personally prefer if we use the software name, “ArduPilot Rover” over “Pixhawk Rover”. ArduPilot runs on tons of different flight controllers including those listed here.

I just found a bug in the latest code, sorry for that :frowning:
So please follow these instructions:

  • Use ArduRover or ArduCopter from master.
  • compile it and download the FW to the vehicle.
  • set EK2_USE = 0
  • set EK3_USE = 1 (use EKF3 instead of EKF2)
  • set EK3_ALT_SOURCE = 3 (Beacon)
  • set EK3_GPS_TYPE = 2 (2D position only)
  • set SERIAL3_PROTOCOL = 13 (Beacon instead of GPS)
  • set BCN_TYPE = 2 (Marvelmind)
  • Use Marvelmind FW >= 5.77
  • Set “Raw distances data” parameter to enabled in the marvelmind GUI dashboard.