Mapping a lake with ArduPilot

We have used airboats with custom fiberglass hull, they are pretty inefficient. We use EDFs for power, and proper rudder for steering. There is no issue with reverse though and pixhawk is perfectly capable to drive it.

1 Like


We’ve got a wiki page with instructions on how to connect the HST-WSU 200. ArduPilot does not yet support reading in the temperature from NMEA devices but I will hopefully add support for this in the coming weeks and then hopefully include it in the Rover-4.1 beta release which should start within a couple of weeks.

1 Like

Must use DST-2 ?

What is it DST-2 ?

It,s wiring not work ?


We’ve added support for reading the temperature from a NMEA sonar and this will go out with Rover-4.2.0-beta2 within a couple of days. Txs again for the report.

Sorry I didn’t see your other comment earlier. To give some higher level information, you need to be using an ArduPilot compatible autopilot (there are many to choose from) and then you need to attach a “digitizer” (e.g. the DST-2) to the sonar to convert the analog signal to the NMEA protocol. Then you must connect this NMEA output cable from the digitizer to one of the autopilot’s telemetry ports as described on the wiki.


my dataflash has no DPTH - log_bitmask=65535 - how do we turn it on ? ardurover v4 pixhawk and ping1d which is using SONARRANGE nicely - just not logging…


The most common issue is the RNGFNDx_ORIENT parameter needs to be set to 25 (it defaults to zero).

How do I set the appropriate throttle? My differential control boat, which parameters can be set to make a gentle and gentle U-turn and sharp-angle turn, the action is too intense now

Hi @He202112,

Can you post an onboard log of the vehicle doing a turn?

You’ve followed the tuning instructions on the wiki of course? There are two relevant pages, the most important is the turn rate control tuning. Next is the pivot control tuning.


I want to install the Echologger ECT400 on my Pixhawk Cube orange.

(firmware Rover 4.1.4 OFFICIAL, mission planner 1.3.75)

In my full parameter list, I can’t find the following parameters.


RNGFND1_MAX_CM = 10000 (i.e. 100m). This is the distance in centimeters that the rangefinder can reliably read.

RNGFND1_ORIENT = 25 (i.e. down) if mounted on a boat

Will this be a problem for the installation and operation of the Echologger ECT400?

1 Like

have you enabled one of the rangefinders within the parameters yet? Until you enable one of the rangefinders and refreshed parameters you will not see those until you do so. once enabled do a parameter refresh and you should now have a drop down menu with all those options.


Yes as @Matt_C says I think you’ll need to also set RNGFND1_TYPE to 17. The setup instructions are here on the wiki but you’ve probably seen them already.

By the way, we hide some parameters until the _TYPE or _ENABLE parameter is set to a non-zero value to reduce the parameter list for users. We have so many features in AP that we also have a massive number of parameters (well over 1000) so hiding some helps keep things manageable.

1 Like

Thanks for your respons. Problem is solved


Hello to everyone,

first of all I’ve bought echologger ect400 with serial output. The echo sounder has arrived and I am very enthusiastic about the first results on the pc.
However, I’m having trouble connecting to pixhawk (the orange cube). For the connection I am using a converter (I have already tried two different ones) rs232-ttl and despite all the parameters are set correctly as in the wiki (Echologger ECT400 echosounder — Copter documentation) the data did not arrive at the pixhawk. Also the converters microcontroller get very hot, and this seems very strange to me. The echo connected directly (rs232-usb) to the pc transmits data without problems. The converters get hot only when the ect400 is working. If for example I invert tx with rx (I’ve done it because I thought the connection was wrong), the max3232 get cold. I can’t understand what’s happening.
Thanks in advance for help/reply


hmmm… hard to guess what the issue could be. We probably need to see the serial output that the echologger is outputting.

Maybe also include a parameter file or better yet an onboard so we can check the parameters. It may be necessary to set LOG_DISARMED = 1 to produce a log while the vehicle is disarmed.

Thank you for the reply.
Ok, I’ll do them. I’ve set ect400 to “altitude nmea” autput, and I see this protocol on serial log. I think that there’s something of wrong on hw point of view. Serials converters wouldn’t get hot as they became at the moment.

Problem solved!
It was caused by a wrong conection with the M-M serial adapter!
Any idea to how to export a .csv file from log with X, Y, Helipsoid alt, depht?
Thanks in advance

1 Like


Great! We have some information on this wiki page re how to extract DPTH message to a .csv file using mP.

Few water surface features may lead to holes in data acquisition modeling. Is there a better solution for this?

Considering that a rtk receiver is installed in my boat, is there a way to make the ellipsoidal high appears together with the depth in the same table, as well as lat and long? It is indispensable for long surveys on rivers.
From what I can see the gps and sounder pings are not in sync. Is there any way to sync them?
Thanks in advance

Hey @rmackay9

First nice work, I’m trying t build something similar to do some surveys and I have two very “noob” question if you don’t mind.

I noticed that you use the Here GNSS module (from videos) and from the echosounder data sheet it’s mentioned that there is a GPS module integrated within.

My first question is, which one is outputting position logs to the ardupilot and then later being extracted along with the depth measurements to the reef master software?

My second question is, If it was the Here GNSS module that was being used, Is there any requirements on were to place the antenna on the robot relative to the echosounder? or it’s a matter of tweaking an offset parameter on the ardupilot software?

Thanks a lot.

1 Like