Servers by jDrones

Map not working for Tower app!

Good day,

I have trouble with my Tower app, I have downloaded it from plays tore and then from here http://app.mi.com/details?id=org.droidplanner.android.fuav
My problem is that there is no maps just shows a blank screen with a google maps icon on the left bottom corner. everything ells works fine is just the maps and really want the maps to work. At the moment I’m using QGC to have the maps showing. Anther thing the voice promotes do not work on Tower or QGC, it works fine when I connect it to Mission Planner on the PC. Please help if I am doing something wrong or if there is a setting to be change.

My Setup is with a Radiolink Mini Pix with V4.0.3

Thank you in advance

1 Like

Yes, you have to go to settings—user interface----enable speech output,you need to have internet connection to see the map,

Hi Cala2, I have checked and everything is on. My internet is always on as well.

I am having the same issue, it is Skydroid Tower App. It seem like can’t connect to Google Map services.

1 Like

Im going to check mine when return home if still working, I have the latest I supposed. You are running with skydroid radio?

Yes, the Skydroid T10. I have uninstall the app and try to reinstall is from the link I have mentioned before but for some reason it doesn’t give me the app that was there. I reinstall it from play store but still nothing…

İ have same issue tried in different Androids and same problem, help pls

Guys, have to install the semi Chinese version to get the map to work. Comment if you need the link.

Can you send link please ?

Thnx

hello yes me too same problem I have T10/R10 skydroid and FC jiyi K3-A…its now 2 months still cannot use it…it will be great if someone have the solution to this problem….tq

Map is working for me skydroid vers 6.6 with M12L

hello friend can I have the map link please…tq

I hope they are migrating the download because I cant found now, their page isnt working too http://www.skydroid.xin/?type=news&S_id=7
This was the older one were it was http://app.mi.com/

Here you can find an older vers, this worked for me too in the past

here you are:
https://m.wandoujia.com/apps/8058257/download/dot?ch=detail_normal_dl

1 Like

Thx, it work for like a split second and all the maps is gone again :see_no_evil:

Really? Can you take a screenshot let me see? It happens when going into the app first time, as it locating your current location n loading the map out. I takes awhile, but it will show somehow.

I left the app running for 5min and still blank.

Thx the maps just started to work :clap:t2: I just left it running and change the settings around…

Thank you bro ! U madde mu day :slight_smile:

Servers by jDrones