Manual Landing Gear not working [solved]

Hello everyone !

Today I finally installed my retractable landing gear on my Tarot 680 Pro

Everything is OK when I set AUX1 ( Servo9 ) function to ‘RCIN7’ which is my Radio Input to control my LG, it retracts when a change the switch state.

But I want to try the Auto retract feature, so I set this up on Ardupilot :

RC7 → Landing Gear
Servo9 → Landing Gear

Parameter list : https://imgur.com/a/ga9PfK3

Servo Output : https://imgur.com/a/4kYyAeS

RC Setup : https://imgur.com/a/aws1jcw

But there is no way to manually control the landing gear with the AUX1 set as ‘Landing Gear’.

I also checked, Yes the RC signal is above 1800us when High and below 1200us when Low, as asked, but nothing happen when I move the switch on the Radio.

BTW, the same thing happend when trying to set up the Gripper : Servo Function set as RCIN : OK, when set to Gripper, and with everything correclty set up, nothing happend on the PWM output …

I ran out of ideas so hope someone can help me !

Setup :
Pixhawk 4.1.15
Radio : Flysky FSI6X
Receiver : PPM IA6B Flysky

Regards,
Hugo

If you configure the landing gear and/or the gripper to be automatically controlled by software then, per definition, it will no longer be controlled manually by the RC.

@amilcarlucas Thanks for replying.
But Then why on this page they’re saying Manual can override Auto Function and vice-versa ?
Link : Landing Gear/ Retractable Camera Mount — Copter documentation

Here :

“The gear/ mount can be manually retracted or deployed with an auxiliary switch. The gear will also automatically deploy during landing and/or retract during takeoff”

They say “also” which can make me think it’s possible to control it Manualy and automatically, which make sense in case of emergency

is the copter armed during your tests?
is it flying?

I found the issue.
RC Input low state was below the failsafe (975) so it didnt worked.
I figured that out when I assigned a pot to the RC channel and then it finally worked in both manual and auto.
Thanks for help