Manual did not work

I loaded for my rover and Pixhawk cube the software, I followed the instructions as Ardupilot sais,

I did the compass & radio calibrations,

the flight modes are set and ok

I checked radio disconnecting and connecting directly and the servos are working correctly. I reconnect the servo to 2 & 3 main out and the sbus to my X8R Receiver

Channel 8 in manual mode

And the rover did not work in manual neither in auto

Thank’s for your help

Did you arm the system?

Hi David

Yes, i armed the system amb the buzzer confirms the activation and no rrsponse grom servos


Post a flash log. How are you powering the servos?


the way to start to play with the crawler is disconnect the protection for throttle and now is working.

The following problem is my crawler has 2 directional servos for front and rear wheels.

The front servo is number 2 and turns perfect, but I don’t know how to setup the rear servo

for example if I want to turn left the front whhel turn left and rear to the right, and I don’t know how to do it

Thank’s for your help


I have an idea if you can post your parameter list so I can see how this is set up.

Hi David

How could I export to a file?


Is the rear servo plugged into an output on your on your autopilot?

Hi David

When I connect the rear servo the front one starts to gitter and did not respond

that’s how I set up


Servo 4

But the main issue is the gittering when I connect to port4

Thank’s for your help


thank’s for your help

I don’t know why that is. There is or was a bug in 3.5.0 RC1. I don’t know if that is the problem or not. You may want to go back to 3.4.2 while getting this set up. How are you powering the servo rail? Did you try and reverse the front and rear servo connections to see if the same thing happens?


I installed version 3.4.2 with the same result and that’s why I chose 3.5 to see if something change.

I powered the servo as following

I reversed with the same result

I’m not understanding something here. It looks like you have no power module or servo rail power supply and only USB power coming in

No, no the Rover is powered from Power1
But I think the problem did not come from power, I connected to port 5 and the rover works perfect, but if I connect to port 4 the front servo start to gitter

Is it possible instead of assign to a ground steering, make a mix of channels or something like this?


Set SERVO1_FUNCTION to 26 and plug it into 1.


I installed rover version 3.4.2 and Looking for this function I could not add 26 it is a dropdown list


Sorry. I was talking about the full parameter list. Function 26 is ground steering.

I did and still gittering, I think that could be a power problem, may be I need more power.

Did you know how to increase power? I think that the new receiver plus two servos there is not enough power. How could I increase the power? changing the ESC? what did you recomend me?

thank’s for your patience

I don’t know what you are powering the servo rail with or with what voltage or amp capacity

oki, thank’s for your help again