Mandatory setup button not showing in APM Planner

I’ve been working on a 3dr quad for the past twelve weeks at my middle school and I have built everything according to the instructions as far as I know. For the past 3 or 4 weeks I have been just trying to get the autopilot to connect via mavlink in Mission Planner and more recently APM Planner and I have finally gotten it to connect using APM Planner. My problem at this moment is that i can’t find the mandatory setup button in the initial setup tab of APM Planner. the instructions online show a mandatory setup button and say to use that to finish setting up my quad. If you have any advise or know anything that would help it would be greatly appreciated.

(Do keep in mind that though I’m pretty smart, I am still in 8th grade so really high level complex terms would be somewhat confusing)

you need to be connected using the connect button in the top right of the view. When you are connected the Mandatory button will appear. If you click on one of the boxes next the to connect button a setup window for the serial communication port (com port) will appear ie USB port selection. You need to select the right com port that the board is connected to and the baud rate should be 115200

This is a screenshot of what I see in the initial setup screen. I believe I’m using the correct COM port and Baud rate but the mandatory button still hasn’t popped up. Any thoughts?

You are connected to the com port, but you don’t have any data flowing as the heartbeat indicator is not showing valid packets being received.

Have you installed a version of the firmware to your APM? (it’s shipped with nothing installed)

Yes, I have installed the firmware.

Try following the instructions here.

Also please describe the steps you have taken to connect. Also look to see if your APM shows up in Device Manager (press the windows key and type in the name in the search box device manager as this is the quickest way of starting that part of the control panel)

So far I have followed these instructions and the instructions You have posted a link to. I’ve only tried connecting to apm via the USB so I’m going to try connecting using the radio but after that I don’t Know what I’ll do.
I can tell that APM Planner senses the quad though and I do see the apm in the device manager.

Before doing all of this work on APM Planner, I also tried using Mission Planner but it always would say No heartbeats received. right after I finished building the quad, I used the wizard in mission planner but then a week later it stopped connecting to mavlink.
Should I try using Mission Planner again?

Try connecting using the terminal view only. You should see a steady stream of data (ie. Heartbeats) if not something else is a amiss (or HW failure). Again, plug in your APM and connect in Terminal mode. Press enter three times to start enbale the CLI (Command Line Interface).

type ‘setup’, then ‘erase’ (without quotes) this sometime can fix the issue

I just tried what you said and after erasing I assumed that I was supposed to install the firmware again so I did just that and this is what I saw in the terminal

Should I have the ESCs connected, the receiver?
Basically, what I have plugged into the Autopilot right now is the usb to the computer, the output wires to the motors I believe, the compass/gps, and the telemetry.
I’ll post a picture in a minute from my phone.

Actually the bell’s about to ring but I’ll try sending it tomorrow. Thank you for your help and patience.

A picture would be great

Hi, I had this happen to me, drove me nuts,

unplug the compass (4wire connector from the GPS/compass) and see if you can see the mandatory setup button after you restart MP or APM. (cycle the power on the copter too).

Also, my HUD and all of the other telemetry data below it would not function with the Mag compass 4 wire cable installed when connected by USB cable.

somthing else to try.


I am having this same issue.

I had it working previously, but was running into trouble setting my elevon configuration. I thought I would try from the beginning and re-calibrate everything. I reinstalled the firmware, but am unable to see any of the mandatory setup buttons, exactly as shown in the original poster’s screenshot.

I removed the GPS compass unit to see if that would fix it, like you suggested, but it did not. I have reinstalled the firmware and the Planner software. Nothing seems to work. I can install firmware, and it appears to download to the device, and It shoes that I connect to the device, but still no options. I have tried multiple USB ports and cords as well.

It is frustrating because I was so close to completing this project, but now it seems completely botched.

At this point. All I have connected to the USB is the APM 2.6 module.

Can you post the HW you are using, and the log file from AP2 after an attempted firmware update.


  1. start AP2 and select the Install Firmware
  2. Select firmware to install
  3. on completion close AP2

then compress (zip) the file in your <home_dir>/apmplanner2/log.txt and attach here

<home_dir> = c:\Users<your_username>\ on windows
<homw_dir> = $HOME or ~ on linux/OSX

Thx :slight_smile: