Making Follow mode work


Hi Randy,

I wonder if you could share the setup steps, that are required to make Follow mode work. I have two rovers running Ardurover 3.5 and they both have companion computers running mavlink-router. At the moment, one rover provides an access point, where the other rover can connect to, or they can both connect to another access point, running on my laptop or my phone. I can forward the telemetry from any of the rovers to the other one. They both have different MAV IDs. What else do I need to do?




The details should be here on the wiki. There is possibly one issue in that the FOLL_DIST_MAX parameter might need to be set to a large number (like 1000m) because Rover is not correctly reporting it’s altitude above home (it is sending it’s absolute altitude in one of the mavlink messages).

Hm. Did you update that page recently?
Because the last time I checked it, the whole bottom part with the parameters was missing (at least for me, perhaps it did not load correctly).
Anyways, thank you and I will try this out as soon as possible!

1 Like

yes, we updated the follow-mode wiki page a few weeks ago… before that, like you said, it was incomplete…