Servers by jDrones

MacOs APMPlanner 2.0 - version 2.026 - Problem crash - missing / wrong QT-Library

After installing APMPlanner 2.0.26, app crashed with a library error QT 5.9.x is needed. Currently on my system QT 5.6 is installed.

Dyld Error Message:
Library not loaded: @rpath/QtOpenGL.framework/Versions/5/QtOpenGL
Referenced from: /Applications/APM Planner 2.0.app/Contents/MacOS/apmplanner2
Reason: Incompatible library version: apmplanner2 requires version 5.9.0 or later, but QtOpenGL provides version 5.6.0

1 Like

FIXED:
Update to daily build : apm_planner_2.0.27-rc1-6-gc64ead1_osx.dmg

4 Likes

Thanks for the tip! Just hit the same problem. Resolved by this update.

1 Like

Thank you very much!! Finally I can get to use APM in my MacBook.

Thank you! Had the same issue. Thrilled to finally get access to APMPlanner 2.0 on my Mac. Just in time for my next build: Pixhawk 2.1 “The Cube”. Ben

Servers by jDrones