Servers by jDrones

MacOs APMPlanner 2.0 - version 2.026 - Problem crash - missing / wrong QT-Library

(Bernhard Klein) #1

After installing APMPlanner 2.0.26, app crashed with a library error QT 5.9.x is needed. Currently on my system QT 5.6 is installed.

Dyld Error Message:
Library not loaded: @rpath/QtOpenGL.framework/Versions/5/QtOpenGL
Referenced from: /Applications/APM Planner
Reason: Incompatible library version: apmplanner2 requires version 5.9.0 or later, but QtOpenGL provides version 5.6.0

1 Like
(Bernhard Klein) #2

Update to daily build : apm_planner_2.0.27-rc1-6-gc64ead1_osx.dmg

(brig) #3

Thanks for the tip! Just hit the same problem. Resolved by this update.

1 Like
(Camilo González) #4

Thank you very much!! Finally I can get to use APM in my MacBook.