Servers by jDrones

M8n gps - pixhawk and qgroundcontrol


(fagnou) #1

Hello !

I use the Pixhawk flight controller with a u-blox GPS m8n and QgroundControl software.

GPS data does not appear in QgroundControl . I tried to modify the GPS configuration with U -center based on ardupilot documentation and supplied file for m8n but

I get error messages (timeout ) and after U -center crashing !

I tried update with AssistNow online but in this case I have an ’ invalid token’ .

Is there an equivalent procedure like Ardupilot to update Ublox m8n GPS through Qgroundcontrol ?

ArduPilot file for m8n GPS can be used ? or is there an alternative file to Qgroundcontrol ?

thanks


(WickedShell) #2

What version of firmware was on the pixhawk?

If it’s a new enough version it will output some information relevant to the GPS on startup. Does it ever report selecting a driver/detecting the GPS at a baud rate? It should be capable of outputting the hardware and firmware version from the GPS depending upon the version of firmware you have on the vehicle.

However if u-center can’t see the GPS that’s not a good sign.


(fagnou) #3

Hello WickedShell, i found ! I’m just try the GPS outside, and it can receive the satellite indoors !:blush: