LW20/C Laser altimeter

Serial4/GPS2 is on the peripheral power supply, which means you might be running into the same power problems that I described above. You can use disarmed logging or LEDs (HERE GPS works) to see if your peripheral power is browning out. If so, you can either use my hardware hack to get it to work, or use the Telem 1 port instead, which has a much higher current limit.

Update, i’m still have problems. I’ve updated all the software, changes the Baud rate to 19200 on the LW 20B and 19 (19200) on serial 4 of PH2.1. I’ve hooked up a separate 5v power source, i can see the LW 20B is on but PH2.1 still not seeing it at all. Again i’ve got TX of LW to RX of PH2.1, RX on LW to TX on PH2.1.
Any ideas on why i’m not getting any readings on the PH2.1??

Ok, i am in the same boat as you guys now. Connected directly to my Pix2.1 and it reads zero, no matter what.

Connected to pc trough serial works fine.

Do we have to wait for a firmware update to have it working?

p.s. strange thing is that when i first received it and having read all the probs i tested it and it worked perfect as reported in my previous post.

Trying to upgrade it the upgrader tells me there is no a suitable port to use.

Same usb to serial i used to connect to the unit with lightware software and it connects fine.

It looks like my dongle doesn’t like the upgrader, any hints?

Is there any news on this?

Lightware released a firmware update for the LW20/C. It didn’t work for me (i2c mode) but tell me if you have some luck.
https://support.lightware.co.za/

Hello, thanks!
My unit is a SF20/C. My firmware when connected with lightware suite is 2.0.0 and i am unable to connect with the upgrader linked here some days ago, hopefully i’ll have more luck with latest firmwares.

I’ll test tomorrow and let you know.

Corrado

Tested new upgrader but on my SF20/C doesn’t connect, same as preceeding one.

I am only able to connect to it trough serial with my pc and it works but upgrader no joy…

I2C connected to PH 2.1 doesn’t work.

I wrote an email to lightware, left a comment on their review page and asked infos here. They didn’t take 2 minutes of their precious time to even answer to me, i guess their customer care is greatly under par in my opinion.

So all it is left to do is waiting for them to tell us what to do with this rather costly object we all have on our tables…

regards,

Corrado

UPDATE:

It was a mistake done by me, i recrimped the original cables and being smaller in diameter than the nominal it should have been it was not crimped correctly and didn’t do a proper contact.

So i can confirm SF20/C works fine on I2C on 3.6 rc8 ChibiOS

My SF20/C on the lightware app shows firmware 2.0.0 (came like that out of the box)

regards,

Corrado

Just for clarification, is this after using the upgrader to put the 20/C into I2C mode, or is it working without changing any settings?

It is working without changing any setting. Actually my SF20/C doesn’t even connect to the upgrader, it cycles all the comms without connecting.

So the answer is yes, it works out of the box and the firmware shown connecting it to the lightware terminal is 2.0.0 (maybe SF20/C has a different firmware from LW20/C).

regards,

Corrado

I’ve tried a brand new LW20/C and upgraded to the latest firmware. It doesn’t work for me with Pixhawk 2.1 and ArduCopter 3.6-rc8. I’ve then tried 2 other LW20/C that were previously upgraded to the 1.2 firmware version I believe but the updater is unable to communicate with them.

I have done heavy investigation over the last few weeks and have written a guide here that will hopefully resolve the issues: https://github.com/LightWare-Optoelectronics/pixhawk-guide

In addition, the Upgrader tool as linked in the guide will help anyone who set their device to I2C boot mode only. The tool can communicate over I2C via a Devantech USB-ISS adaptor.

I would appreciate any feedback about your experience with this so we can merge the guide into the official ArduPilot documentation.

My rangefinder had worked great since the recabling, i still have a range issue that i am trting to understand.
My unit a SF20/C is supposed to work up to 100 meters but stops reading at about 50 meters, i wrote to lightware to understand by my unit serial if by any chance the shop sold me a /B (50 meters unit) by mistake.
As usual no answer from lightware…yet

Hi Corrado_Steri,

Please see my private message to you.

Hi Rob,

Out of 3 LW20/C that I have, only two have been able to work consistently with Pixhawk 2.1 after upgrading to latest firmware. The other LW20/C has been upgraded to firmware 1.3.1 but doesn’t report any data back in Mission Planner (only 0.00 but works in Lightware Terminal).

Any pointers on how I can fix this ?

Thanks,
René

Hello Rob, thanks for the support so far. The I2C compatibility mode is a nice way for users to get the 20/C to work without having to wait for a new driver in a an ArduPilot release.

Have you had a chance to look into the power-related issues I mentioned above?

The short version is that when the 20/C is set to force I2C or force serial mode, it overdraws the Pixhawk 2.1’s peripheral port when the lidar is first powered on. The older LW20/SER and LW20/I2C lidars do not have this issue. Interestingly, the 20/C does not do this when set to “select interface” mode, apparently because it “soft” boots into a lower power use mode (~60mA) before operating (~100mA). It’s only the initial current spike when it boots that causes the problem, the constant current draw during operation is fine.

Hi Rene,

Can you confirm if you are using I2C mode or Serial mode? And if you are using I2C mode can you confirm you have the startup mode to ‘Wait for interface’ and the Pixhawk compatability enabled? You can recheck using the Upgrader and it should show the current state of the LW20.

Hi Rob,

I’m using the I2C mode on the Pixhawk 2.1, the the startup mode on the LW20/C is set to Wait for the interface and the Pixhawk i2c compatibility mode is on.

René

Hi Rene, can you check that the i2c address is as expected for the third unit?