Lua Script Missions Planner REPl Failed to start

Hi guys, I’m starting to play with some of the lua scripts and was trying the REPL however I cant get it to start, im just getting REPl Failed to start .

This is Cube Orange on Copter V4.0.3 and scripting is enabled.

I’m connecting via USB as well to the controller

The REPL should now be working on beta MP.

Thanks Pete, I will give it a try :sunglasses:

I’m seeing the failure notices on REPL on hardware. I’m running 4.1.3 on a MATEK F765-WSE hardware and the latest Mission Planner build. QuadPlane configuration. MP fails to connect and crashes. Thoughts?

I’m afraid it got broken again, try a older version.

Older Mission planner or firmware?

Older mission planner version.

Thanks Peter. Tried *.70, *.72, *.73 and 74. MP no longer crashes and no errors pop up but it does not connect.

I get an Error when I try to Connect with REPL. The error screenshots are attached. When I click OK, the MP program closes.

I’m using MP 1.3.76, ArduCopter V4.1.3 and Pixhawk 4 connected via USB. I have tried on a desktop and laptop PC running windows Version 10.0.19043 Build 19043.

Here are screenshots: I click on Connect and I see the following.pdf (68.8 KB)

I downloaded the source and built with VS 2022 Community Edition per the instructions here in the README.md file.

Then I got everything working by commenting out the line that throws an Exception: line 1961 in function kCmdWriteFile.

The error says EIO (input/output error). My guess is that the timing needs to be increased somewhere as this operation does take some time.

Can someone suggest how to fix permanently?