Low throttle hover, MAG issues, and DSHOT600

Alright got INS_NHTCH_ENABLE=1, INS_HNTCH_FREQ=134, INS_HNTCH_BW=66, then set INS_LOG_BAT_OPT=2 for post filter analysis. Looks like made a good dent but still have some smaller peaks around that harmonic. Maybe increase bandwidth?


Post Flight HNTCH 1
Post Flight HNTCH 2

Thanks, that’s what I am using but it oddly showed a much more rounded part before that 134 peak. More just making sure I’m not missing something to give be better visuals. Here is that pre filter zoomed in on mine.
Preflight Zoomed 134

Disable the 2nd Notch Filter. And this is what you have on the 1st:
INS_HNTCH_BW,76 (should be 67Hz)
INS_HNTCH_MODE,1 (throttle reference)
INS_HNTCH_REF,0 (This needs to be at MOT_THST_HOVER for throttle reference)

You have Dhsot configured but no ESC telemetry? The best option would be to flash the Bdshot version of the firmware for that board and use that as RPM reference for the notch.

But to answer your question the magnitude of those remaining peaks is in the mud and of no consequence.

MAVExplorer and MP seem to present the data slightly differently. At the end of the day I don’t think 134 vs 126 will make a really big difference, if any at all. Looking at the graph you posted above using 134 I’d say that works just fine and don’t mess with it. Then take Dave’s advice for the rest of the settings.

Ah I must have typoed that bandwidth when I entered it, I will fix that and also the INS_HNTCH_REF.

I think I had telemtry enabled at some point early on but was switching things around trying to fix my original DSHOT600 issue. I will take your advice and get BDSHOT flashed on there and then update the INS_HNTCH_MODE to RPM.

I actually tried flashing Bluejay but for some reason it wasn’t even seeing my ESCs even though it’s supposed to be supported.

I really appreciate all the help here!

Ah thanks I got a bit mixed up since I was in MAVExplorer looking at the Magfit function. I won’t worry about the difference there! Thank you!

Hey so I was able to get Bluejay installed now, loaded 4.2.2 bdshot firmware, set INS_HNTCH_MODE=3 for ESC Telemetry and then set SERVO_BLH_BDMASK=4 for Channel 3. I disabled arming checks, tested on my bench, worked great, proper thrust and control.

But then I reenabled arming checks took outside for a test flight, plugin, get ESC tones, then a double beep, then ESC tones again. Wait for satellites, go to Arm, get a long tone, no messages on OSD, but then only the right side motors arm (and they do respond to TX). Completely at a loss here as what could be affecting it.


This needs to be set to 15 if you have motors connected to the 1st 4 motor outputs (which you do). And you are not getting ESC RPM thru Bdshot. Either because this parameter is incorrectly set or it’s not working with Bluejay. Open the log and if you don’t see a ESC data field it’s not working.

Thank you! That got the ESC reporting now in the logs. I am still getting the double ESC chimes though and not seeing any messages about it, worries me there is something that will cause an issue on next flight… It did arm and have proper throttle response inside. It’s too dark to take outside for a test flight but can you see anything off that I can review tonight?


BlueJay has different tones to BLHeli - you know that presumably?

Yes sir, so I actually added my own custom melody. It plays the melody, pause, two beeps, pause, then melody again, like it’s initializing twice. I don’t recall it doing that before.

EDIT: Sorry for double post, my app glitched out

Hi chaps when you say ignore the warning for PSC_ACCZ_P & I being out of range do you mean leave as default values?
I have an extremely grunty Hexa and it’s mot_thrust_hover is 0.125 (no payload)

Is it possible to move straight to Harmonic Notch Filtering without making changes to the above?


No. Set it to the correct values based on MOT_THST_HOVER and ignore the warning. Many of those warning are bullshit and don’t apply to all craft particularly high thrust/weight ones.

BTW-If you say MOT_THST_HOVER is at 0.125 because that’s what was learned understand that it won’t learn a value <0.125. So, look at CTUN>Tho in the log at hover for the real value if it’s likely to be lower.

Right. yeah very different from my EDU450 as expected.
I read between 0.103 - 0.107 on the logs. it’s much lower than 0.125 so thanks for putting it out.

Subsequently, I moved to the next stage of the process.

I’ve run an Althold for over a min with INS_LOG_BAT_MASK so I have that data set aside as well.
Following the wiki (This will enable FFT logging) I then saw FFT setup under optional hardware where it points to sample count. I haven’t found anything on this so assume this is left at default?

Regards Anthony

You will use the data gathered in that log to configure the harmonic notch filter. Mission Planner → Setup → Advanced → FFT → IMU Batch Sample → Choose your logfile. This will give the graphs for that filter setup as here:


thanks, Bryan, I’ll head down that route today.

I found it interesting what you said about Mot_Thst_Hover being limited to 0.125.

I was following the wiki waiting for CTUN.ThH to climb. Never occurred to me it would be so powerful it would be below that. The cutoff just shows a straight line at 0.125.


Oh fyi that wasnt me, that was Dave lol. I am still learning so not sure what to say about that, I just knew enough to point you to the FFT stuff.

1 Like

It’s not limited, learning MOT_THST_HOVER is. You can manually set it to whatever you want and should if it’s below .125

Thank you Dave, great help.