Low GPS Speed causes dive into ground

I have a flying wing with a Pixhawk Mini and airspeed sensor running Arduplane 3.8.4. It has operated well for many missions. I have recently had two bad nose dives (called Max 8 crashes) which seemed the same but the telemetry says different.

The first from stable flight at 50m AGL at 14m/s airspeed into wind of 6m/s:
I triggered the problem by manually nosing over to a 45 degree dive by mistake. However, switched to stabilize within a second and it did not pull out. It appears the 45 degree dive caused the GPS speed to reduce below Min (it should by geometry) and so although the air speed was fine I believe Ardupilot thought it needed to speed up and did not try to pull out until too late. It was low and hit the ground before I reacted. GPS speed dropped rapidly to 1.3m/s and then increased to 7.5m/s. Airspeed increased uniformly to 32m/s. Airspeed_FBW_Min is set to 9m/s, Max is 22. Is this a known effect on ground speed causing trouble? Is the GPS speed taking priority over air speed? If you would like to look at this further I can attach the bin file.

The second crash looked the same but was different because it was already at high air (24m/s) and ground speed (20). It tried to pull a hard turn at 45 degrees bank and then appears to have not had elevator authority to pull up but it also did not try hard. It held in the 45 degree bank and up elevator mixed on the elevons. But both speeds increased. Neither elevon was at max travel, in fact the inside elevon is near neutral in a turn to effect the turn. I don’t find a fault and wonder if this is a problem of a wing and elevons being unable to pull a hard turn and pull out of a dive. If I had worked it out I would have reduced ailerons and so enabled more pull up. But from 35m it hit the ground first. Another stunned mullet reaction!

So as not to cause concern; you will see I fly at an airfield but I monitor the CTAF and would land if traffic called in.


Several times, I’ve flown in auto mode on windy days while my Craft and Theory telemetry (on a Taranis radio) starts announcing “Landing Complete” as the plane essentially hovers about 90 meters overhead. Not sure what the threshold is for that message, but the plane is essentially stopped in the sky and I need to nudge the throttle forward going upwind if I want to continue the mission.

Based on that experience, so long as you set the “Airspeed Use” parameter to on, the aircraft should be happy moving at very low, zero, or even negative GPS speeds.

Now if your airspeed sensor is not reading high enough and you are trying to use it…the flight controller will attempt to dive to gain speed. Leaving the pitot tube covered while flying in auto mode is a prescription for disaster. My preflight procedure now includes verifying both:

  1. That indicated airspeed is less than a m/s with the pitot cover on, and

  2. That indicated airspeed increases with wind (momentarily pushing the cover back on and off to jump the airspeed up).

But it sounds like you have looked at your airspeed and believe that it is in the ballpark of reality.

You can look at the desired pitch vs actual pitch in the CTUN parameter set to see if the controller was trying to pitch up or not. Throttle output will tell you if the controller wants the plane to speed up.

Thanks Roger,

I have tried a few things but don’t totally trust it. So I avoid changing to auto near the ground and am ready to change back when I do. I now also understand the various semi-automatic modes better and realise they don’t all control all axies. That caused one accident.