Servers by jDrones

Lost USB com port: Holybro Pix32 Pixhawk (PX4) 2.4.6 FC

May I request assistance.

I’ve been flying this FC in a Multirotor for two years successfully.

Recently I’ve purchased the DJI FPV system kit and was motivated to upgrade the Multirotor with it and utilise the custom OSD via the new MSP protocol support coded in the latest master for Pixhawk 1.

Previously I was running ArduCopter 3.6.2 on ChibiOS, the USB showing as Com 11.

After flashing with the latest master I’ve lost the com port.

I’ve tried to boot into DFU mode by powering on with the reset button pressed. I just get a triple beep and still no com port visible by latest versions MP, QGC or iNav configurator. Nothing found by Impulse RC driver fixer.

Also I’ve tried to boot with the SD card removed with the same result as above. This tried also with the reset button pressed at power up. Along with trying several different USB cables.

The Windows 8.1Pro laptop I’m using works fine configuring my 4 other drones but does require the Impulse RC driver fixer sometimes when swopping from one drone to another.

The Multirotor is flying presently ok and I can configure parameters via the Mavlink / sik radio system which is still working ok.

On boot up and via Mavlink connect to MP I see this message:

Pixhawk1 00400046 35365118 37353630
ChibiOS: 331fe75d
ArduCopter V4.1.0-dev (11b3c622)

The MSP protocol support for the DJI system is not working as I’m informed there might be an issue with the build server not enabling MSP OSD by default.

Consequently in order to get this working I need to flash a new ‘latest master’, my issue being how to do this without a functional com port.

So I’d like to ask if there is a way to flash a bootloader using the Mavlink / sik radio system in order to retrieve the USB com port? My internet searches have not turned up anything I can comprehend on this subject.

Many thanks in advance for any assistance in this matter which could be offered.

Kind Regards

Chris Worth

Further to my previous post, I did manage to see DFU in Inav and Betaflight configurators by repeatedly using the F4 boot pad and Impulse RC driver fixer.

However I’m unable to flash a bootloader or load a ‘with_bl.hex’ file. Both configurators just hang and MP does not see the DFU at any point.

Have I ‘bricked’ the FC ?

Any comments appreciated.

Regards

Chris Worth

Update your bootloader and re-install the MP dirvers.

Drivers.msi from here:

https://firmware.ardupilot.org/Tools/MissionPlanner/

https://ardupilot.org/copter/docs/common-bootloader-update.html#updating-the-bootloader

Many thanks Peter, I’ll have a go.

Best Regards Chris

Hi Peter,

I uninstalled MP then reinstalled the latest MP 1.3.74 build 1.3.7563.27684

Inav and Betaflight configurators see the DFU if I power up the FC using the F4 pin pulled down, MP still does not.

Consequently I’m unable so see how MP can be used to update the bootloader if it is unable to detect a com port.

Any further advice would be much appreciated.

Best Regards Chris

You say you can connect, all you have to do to update the boot loader is press the button in mission planner.

Hi Peter,

Yes I can connect with the Mavlink Sik radio telemetry link only. I neglected to clarify that in my first post, sorry.

Still the reinstalled latest MP does not see the DFU over the USB link as iNav configurator does.

Is there a way to update the bootloader / firmware over the telemetry link ? I’ve searched the net with no hits on this subject.

Many thanks for your assistance.

All best Chris

Yes

Hi Peter,

That’s good, so this will work if I’m just connected to the FC via the Sik telemetry radio and not the USB com port ?

Many thanks Chris

Hi Peter,

I’ve done as above via telemetry and see exactly as your screen shot above and have returned this message:

However when I reboot and connect the usb I see no com port.

Also I’ve tried booting into DFU again via the F4 boot pin powering with the USB connection, after running Impulse RC driver fixer I see the DFU again, but just in iNav configurator not MP.

I’ve again tried to load a local ‘with_bl.hex’ firmware from iNav configurator to the DFU but I don’t see an green loading bar running and the iNav configurator disconnects saying USB not found.

Am I doing anything incorrectly ?

Thanks for your assistance.

All Best Chris

Servers by jDrones