Servers by jDrones

Lost of wifi connection to sv and won't arm

(Lee horscroft) #1

As some know I recently did a reframe into a micro frame (didn’t work) . Anyway after putting it all back into the original frame I lost connection via wifi. So am unable to recalibrate. Since then I have triple checked all connections and replaced the wifi antenna as well, in case I had damaged it. On top of this the sv will not arm. Turns on and Will bind with controler and that is as far as it will go. So my question is really, is there a way I can completely reboot/factory reset the sv via the sd card?.

(Dude) #2

Create a blank text document and name it FACRESET.TXT and place it on the SD card. Turn on the SV with the card in it.

(Lee horscroft) #3

Thanknyou I shall give it a try.

(Lee horscroft) #4

This has not worked . Any other info needed on the 21st card that might help me out? As I only got the blank facreset.txt file on it at the moment.

( .) #5

Just to be clear. It has to be called FACRESET.TXT exact caps. Remember…this is C++ :slight_smile:

From Docs:

(Lee horscroft) #6

Ok every attempt has failed using FACRESET.TXT , facreset.txt, FACRESET.txt . I have even tried a wifi.txt file and nothing works.

Have any of you got a boot up/root log on your sd cards, you can attach to a post for me to download and try?

( .) #7

I’m not even sure what that is. Have you tried reloading the firmware again. I have a feeling that the reason nothing is working is becausde the firmware didn’t finish loading, maybe.

Use the firmware on SD card method. The bootloaded is probably still there. They basically said you “cannot” brick it. (not sure how true that is :wink: )


Flight Controller Recovery using the SD card
If the Flight Controller becomes un-flashable at runtime, recovery is possible using the SD card at boot time.
Place a copy of arducopter.abin in the root directory of the SD card - but change its name to flight_fw.abin
Rebooting will cause the Sonix board to flash the Flight Controller before the STM32 leaves the bootloader.

(Lee horscroft) #8

Sonix board is not reading sd card or generating a wifi connection so have to assume it’s ether bricked or crashing on boot up.

(Satoru Sasaki) #9

I agree your guess that Sonix board is not working. To find it what it is doing really, need to solder wire to monitor UART output. I have not done that.

There is a way to update Sonix firmware via microSD card. Discussed here
One of my SV got from ebay did not connect with WIFI either, fixed by updating firmware.
This readme says

  • FIRMWARE_660R_F.bin is the format to use for updates via the
    microSD card when the bootloader pin is used on the Sonix board

See linked post to identify bootloader pin. You will need to remove metal shield of Sonix board to access.

(Lee horscroft) #10

Thanks. tho all that is well above me. I read it and i don’t understand any if it.

(Dude) #11

Where there any other files or folders on the card? I think I deleted everything and only had the FACRESET.TXT file on it when it worked.

(Satoru Sasaki) #12

@Leztec, your question was to find a way complete reboot/reset SV, reloading firmware (from SD card) gives a good chance. Sonix board requires this step to do so.
It will load firmware from SD card, if bootloader pad (TP4 in Kevin’s post) is pulled down when powered on. Pull down means to connect it to ground.
I did not take picture, but step will be like this.

  • Temporarily solder thin wire to SD card slot metal part (‘GND’ in his photo).
  • Copy FIRMWARE_660R_F.bin to the root of SD card.
  • Connect battery while the other end of wire touching the pad.
    If this boot process goes well, firmware file should be erased but I do not remember well.

Sonix Board Recovery without WiFi?
(Lee horscroft) #13

Thank you guys. I have managed to get it sorted. Could not be more appreciative that you guys was here to help . Massive thanks and i owe you all a beer :grin:

( .) #14

So what was the solution? I assume that reloading from the SD card saved the day.

(Lee horscroft) #15

Using the wire to ground was the solution. I was over thinking everything and stressed and frustrated with it. Once satoru explained it I realised was a lot simpler than I was thinking.

(Dude) #16

Interesting. Never had to ground anything to reset.

( .) #17

Yeah that was all new information to me. @peterbarker can you confirm this? I mean, obviously it worked for Leztec, but that particular step isn’t anywhere in the wiki. If this is the “official way” to do a firmware reset of the Sonix, then we’ll need to add it to the wiki. I don’t think it was ever assumed that the Sonix would get corrupted.

Thanks @Satoru_Sasaki. I’m not questioning you, just wondering if the SV developers have this information as part of the Sonix data sheet.

(Satoru Sasaki) #18

Good to hear it worked. :slight_smile:

(peterbarker) #19

Yep. This shouldn’t generally be required, but will get you out of a
real fix.

It does appear to be missing from the Wiki - PRs welcome :slight_smile:

( .) #20

I don’t fully understand what needed to be done to make it work. Perhaps @Satoru_Sasaki or @Leztec can add it. :smiley: