Loss of control after transition to forward flight [Solved]

I have a new Skywalker X8 quad plane build that I did a test flight with yesterday. The vertical takeoff worked fine but shortly after the transition to forward flight it loss attitude control and rolled back and forth. I switched it to QStabilize and managed to land it in that mode. On the next try I adjusted the COG a bit but the same thing happened. I was a bit low so it hit a wing and crashed.

I’ve had a look at the logs and except for the vibration level getting a bit high I don’t see anything obvious. I’d appreciate some help analyzing what the problem is. The logs from the day are here, files 6 and 7 are the last tests.

There’s a short video of the vertical takeoff here if interested:

And some build photos here: https://flic.kr/s/aHsmmAt3bg

Hi Darrell,

The GPS speed of 10m/s looks rather low when you were in FBWA mode. Since Q_ASSIST_SPEED is set to 12, do you remember if the quad rotors were still helping when it lost altitude? I suspect that the back and forth rolling was the X8 starting to stall. What was the wind level?

The quad rotors look fine in QSTABILIZE mode, but in FBWA mode, only one transitions off. Perhaps re-calibration the quad ESCs would help.


It was a pretty short flight so I’m not sure but it took off and then a second or two afterwards, and below flight speed, it just seemed to give up and start stalling. It looked like the vertical motors slowed down until they kicked in again when I switched to QStabilize. Interestingly enough, a very similar thing happened to another user I’ve been helping had a very similar issue in Thailand. They posted this video https://youtu.be/opyvHMKWKBs

Check your forward power system. In the graph below, C3 (in yellow) is showing full power so maybe you need a bigger motor or prop. It can’t hurt to verify motor and prop direction.

The video issue, and yours, look similar to the issue I have on my Wing Z-84. Check out my thread video in the v3.8 forum. I suspect that certain power system dynamics (quad or ff) create this issue while other systems work just fine. I have had successful flights using v3.8 on my mini Talon and Bix3 QPs.

Thanks Greg. I really appreciate your time/help. The hardware for this airframe came from another Skywalker that I crashed. It had many flights on it so I know that it should fly well. The throttle was at 100% because I raise it to full when switching to FBWA.

I think you may be on to something with the ESC calibration though. I noticed that when I armed it the rear right motor was starting up slower than the rest. I’ve recalibrated the ESCs and made sure they all start equally now. I’ve also raised my Q_Assist from 12m/s to 14m/s although I assume that’s not applicable to transitions?

It wasn’t flying long enough to get up to flight speed before this happened. I suspect that the vertical motors shut off early or as you said, one shut down early causing the stall.

Both of the planes I’ve mentioned are quite heavy at 6Kg. So they need quite a bit of time to get up to flight speed. But I know it works as I’ve had the exact hardware in the air before.

1 Like

I did another test flight today and the results were almost identical. The plane transitions, and after a second or so of forward flight just stops and stalls. The log looks very similar as well. It looks to me like the forward motor (rc3) just stops for some reason. The voltage and current look fine at that point so I just don’t understand what’s happening. I also tested the forward motor on the ground and it’s providing more than enough thrust.

Log at https://www.dropbox.com/s/70earu8hc26ru35/00000009.BIN?dl=0

Your plane has never reached transitionairspeed, set by paramter ARSPD_FBW_MIN in your case to 14 m/s.
The forwardtransition was therefore not completed.

Regards Rolf

My point about the FF motor at full throttle was that perhaps it wasn’t creating sufficient thrust to break the 14m/s speed.

However, I found something odd below that suggests your control issue in FBWA happens before the plane gets going which is why you rightfully put it back in QSTABILIZE mode. The top graph is CTUN Pitch vs. NavPitch and the bottom graph is CTUN Roll vs. Navroll. When you switch to FBWA mode, there is no Nav Pitch or Roll.

Note that the CTUN (throttle and altitude information) graphs the same as the ATT (attitude information) so the vehicle’s actual pitch and roll do not equal the desired pitch and roll. Maybe a PID issue? I assume that you tested the the compensation manually in FBWA mode on the ground.

I always test in FBWA mode on the ground before flying. The control surfaces were certainly moving as expected as I rolled and pitched the plane. This Pixhawk came out of a working Skywalker quadplane and I’m using the same parameters. The previous plane crashed so I moved everything over to a new build.

I’ll be heading to Canberra to fly with the CanberraUAV team next weekend. If we don’t figure it out before then I’ll see if the team members can have a look. Thanks again for your help.

1 Like

Are you using a different version firmware?

It didn’t have enough flight time to reach speed. I’ve done a lot of flights with this same setup and normally it takes quite a distance for it to get up to speed and before the vertical motors turn off. In these flights after just a second or two it’s like it hits a wall and just gives up, then stalls and the vertical motors take over. I have tested the forward motor on the ground and there’s plenty of thrust available. I’ve flown with the same setup many times before.

No. As far as I know, nothing was changed when moving the Pixhawk from the old airframe to the new one.

In one of the logs I saw a spike in current to 100amps. The ESC on the forward motor is 85Amps. Is it possible the forward motor is just shutting down? Although in the recent logs it appears the current on the forward motor doesn’t go above 35Amps, which seems a bit low to me.

Interesting. Please report back if you find out what the issue is next week.

1 Like

Hi @Rolf - The question is, why didn’t the plane reach the ARSPD_FBW_MIN speed? And if it’s under that speed, then why did the transition finish early? In the past, the ramp up to flight speed took much longer. The plane stalls much too early in the process. I’ve checked the forward thrust and it’s available. So again, why is the transition terminating so early?

I suspect issues with the airspeed sensor. I’m going to disable it and try again in a couple of days. If that doesn’t work, hopefully the team in Canberra will have time to look at it. Although the Outback Challenge is getting quite close so their time is at a premium right now.

Went for another test flight today with the airspeed sensor disabled and the results were the same. Tridge suggested that I do my ground checks again as it was very likely the airframe was the issue. I asked a couple of other pilots to watch me perform the FBWA ground checks and they saw what my brain just didn’t register.

When I rolled the plane left the elevons reacted as they should. I had no idea that if the roll worked that the pitch might not. So I just didn’t notice that when I pitched the plane that the elevons were reversed. So of course, when the flight controller pitched up the elevons went the wrong direction causing pitch down, and the plane to flip.

I corrected the reversal and of course on the next flight it transitioned perfectly. Unfortunately during a roll the elevon linkage came loose causing the plane to continue the roll and dive. I was too low to save it with the vertical motors so it crashed hard in to the ground. It’s repairable but given they aren’t that expensive I’ll probably do a fresh build.

Thanks again for your help. I really appreciate it.

Opps! It happens to all of us. I also have a buddy confirm my compensation. Good luck on your repair or new build!

Just curious, and your forward esc? you check at max throttle on ground?.
I follow your results if you find the issue, thank´s for share.

Fine that you have found the cause. And the reason transition speed was not reached is due to the plane has already rolled to the side (kmz-file from 000009.bin):



1 Like

I currently have the same problem. I read the thread but I did not find the reason.