Losing altitude after selecting follow me mode


I have a quadcopter equipped with RPi3+navio2 board running APM 3.4 RC1
I tried this evening to run guided modes for the first time with Tower and it worked great!
I could even realize a “dronie” through the Tower built in functionnality

When I tried “follow” mode, my quad starts loosing altitude down to reaching the ground and not disarming. It even concludes everytime by a flip due to small wind or small ground reasonnance

Does somebody know what I have done wrong?
In the follow me option, the drone is supposed to fly at 20m altitude, therefore I don’t understand…

Thanks very much for your insights

Please update to rc4 as soon as possible, we launch new release candidates because we find issues in the previous ones, so everyone should update.

What Tower version are you using? We know the latest Tower stable version has an issue with altitudes, so I’m pointing more at a Tower fault. But I think we don’t have anyone actually experimenting with Follow Me so it would be good to go to the end of this.

Please use Tower Beta https://play.google.com/store/apps/details?id=org.droidplanner.android with 3.4RCx variants.

As a rule of thumb, beta releases of ArduPilot, usually require also pre-releases of GCS software

To add a little more detail, it’s a known issue that Tower was sending absolute altitude requests. The issue was only uncovered when Copter-3.4 started supporting absolute-altitudes and terrain-altitudes. As @LuisVale says, latest Tower Beta should resolve the problem.

Thanks for the very reactive support
I will bowled tower beta and let you know asap about the result

Altitude control via Tower (beta) works now (AC 3.4 RC4 / Tower v4.0.0-beta.2.)

1 Like

@Hubertus_Paetow, excellent, thanks!!

Thanks for the advice.
I made the test today with Tower Beta and the follow-me mode was working rock solid.
Thanks to the whole community for the very good job and for the support to this question, your intuitions were good!


Excellent news. I’m going to close this thread then. txs!