Loiter - violent pitch or roll when in loiter mode

When flying in loiter mode, the copter seems be fine. The problem when it sometimes drift and try to recover its initial position, it became to pitch or roll violently. I tried to analyze the log file but cannot see anything wrong. But I’m a beginner :wink:.
The copter flies fine in stabilize mode. Alt Hold is ok too, acro too.

Can anybody give me a clue of what’s wrong with my setup ?

I also double checked the compass calibration and re-entered declination. This does not make it fly better…

Please describe the copter. In particular, what GPS are you using?

It’s a quadricopter using :

  • ArduPilot Mega 2.5 Kit
  • GPS Options:MediaTek GPS]

Do you think it can come from the GPS ? Is there any way I can point it down in the log ?

Unfortunately the MediaTek GPS is very poor. I strongly doubt you’d have these problems with a ublox.

Is there any way to be sure the problem is coming from a poor GPS ? The point is that I don’t want to buy another one if this does not solve the problem…

You may be able to get a smoother response by reducing your LOITER_P and LOITER_I gains. It could potentially help to increase INAV_XY_TC as well.

Warning: increasing INAV_XY_TC will cause the inertial navigation to be less stable. Increasing it too high will cause the copter to fly away - be ready to flip to stabilize. You need as close to perfect vibration and compass as possible for this.

You will never match the 3DR UBLOX’s performance with that GPS, though.

I have just installed the new framware on my pixhawk 2.4.8. After all initial set up my copter fly very nice in stabilize mode! But when I go to the Loiter mode It is aggressive and crashes. I have uploaded the logs of my two tests. I do appreciate any help or suggestion.
Frame: x-copter
FC: Pixhawk 2.4.8
Frameware version: ArduCopter 4.1.0 (ea559a56)



Your vibration levels are way to high with 1000’s of clipping events.

Thank you @dkemxr for your quick reply. I had a Hexacopter. Now I change the frame to x-quadcopter. I replace the standard damper with a plate of a sponge. Therefore you suggest using the standard damper to reduce the vibration levels?
I see the GPS error in the *.bin files while the GPS was 3D fixed and the blue light on the GPS module was blinking. The problem doesn’t relate to the GPS somehow?

The GPS glitch may have been partly responsible for the Vibration Compensation failsafe but in any case you have to fix the high levels of vibration.

Dear @dkemxr when I changed the frame ware from Hexacopter to the new X-copter, I thought that the old parameters will erase completely. But many of them work on my new frame ware on X-copter. For example, my range finder, TF03, works nicely without setup its parameter in the new frame ware. This is not strange? I think some parameters which come from my old Hexacopter frame ware into the new X-copter frame ware, cause such problem (violent pitch or roll in loiter mode). Would you please look at my parameters in the below link? Maybe I have to change some critical parameters relate to the Loiter mode or the modes that need GPS. Thanks in advance.


If all you did was change the FRAME_CLASS from hex to Quad then all of the parameters accept motor assignments will be the same. IN any case you would need to re-tune.

I was going to re-tune my copter. My plan was to arm in Stabilize mode then going to Loiter mode (which is not necessary) then going to PosHold then going to tune mode by changing the Chanel 8 to the high. But I failed at the first stage i.e. going to the Loiter mode. :woozy_face: :weary:

I would set the parameters defined in the Initial Tuning Plug-in back to recommended before running Auto Tune. But, it’s pointless to run Auto Tune with high levels of vibration.

Dear @dkemxr today I have done another test with an improved damper. I still didn’t use a common damper and I used a piece of sponge (I do not have enough room to install a common damper). This time I didn’t go to the Loiter mode and from Stabilize mode I issued to start the autotune by changing channel 7 to the “High”. But the tuneup did not start!!! Please kindly visit the log file. Does the high level of vibration disappear with my new dampers set up?
Why I did not go to the autotune mode? As my sticks weren’t at the mid (my guess)?

You can graph the vibration levels for yourself and see they are still too high.

Why are trying to Auto Tune? Post a log of simply hovering in Altitude Hold for a minute or so.

Dear @dkemxr I have calibrated the magnetometer and my problem with Loiter-violent has been solved. But my coper has a kind of tremor when it is hovering. It seems that the PIDs are not well defined. I tried to do Auto-Tune to mitigate such tremors. As my battery doesn’t have so much capacity I decided to tune just the roll axis. I successfully went to the tune mode in position hold mode. But it could not finish the tune-up after around ten minutes of twisting. During the tune-up, the tremors of my copter were disappearing for a short period of time and I was think that the problem of shaking has been solved. But aging the tremors were coming back. Where do these shakes come from? Where do I have to check? I do appreciate any help and/or suggestions. I have shared my log file at this link:

The vibration levels are better but you should set everything back to default, then set the Initial Tuning parameters using the Alt>A tuning plug-in in Mission planner and start over. The parameters that still exist from the previous configuration are not suitable now. Auto Tune will not completre in this condition. In fact there are “Failing to level” errors during the tune.

Summary-Start over and set the Initial Tuning parameters properly.

Dear @dkemxr I start over and I performed Autotune. The coper now is more stable. But still send the “Failing to level” massage, “Auto-Tune: failing to level please tune manually”, “Leveling (Rate (R) 15.1 >10”.
Please kindly visit the log file here: