Loiter turns radius not working as expected

I’ve been playing with the simulator for a quad and found Loiter turns radius doesn’t work. If I set 0 I expected it to do yaw turns in it’s own length or with a radius to whatever, but it seems to stick at a fixed amount or no difference at all, never zero.

Try fiddling to see if it is taking the radius from the CIRCLE_RADIUS
parameter when that value is zero.


I tried CIRCLE_RADIUS and it doesn’t affect it and only effected by it when it’s 0 stopping dead the quad for a length of time then moves onto the next waypoint. Changing radius in the planner does change the radius but setting 0 doesn’t turn on the spot just uses the previous value. I would assume it’s a feature or bug ?

I see the same thing in the Simulator while trying to diagnose a problem seen in an actual flight. No matter what I try when it reaches the LOITER_TURN waypoint it either sits there with the same heading, with a Waypoint radius of zero, or circles at the Waypoint radius but with the same heading. I cannot get it to turn in place.

Yes, I think it’s bug in the simulator.

I haven’t figured out how to lift the throttle either to use other modes circle for example.

Another poster experienced this on an actual flight and I was trying to solve the problem with the Simulator. So it could be a general problem but I haven’t tried it in-flight myself. Blowing 50mph here today.

This issue has already been raised here https://github.com/ArduPilot/ardupilot/issues/14031. It should be fixed soon hopefully!

1 Like

Thank you for the link! No need for me to try an actual flight as the Simulator is doing it’s job producing the bug!

Thanks for the link.

Just an update: The issue has been fixed in the current master. So next stable release should contain the patch! Also, loiter turns is being upgraded to allow the user to control yaw as well (though this PR by Randy is still not merged)