Loiter_to__Alt Command Returns 1 for Radius

I wanted to test out this newer feature tomorrow morning. For heading I put in 1 because I want it pointing into the next waypoint before it exits this command. For radius I put in 300, as in 300 meters. I put my alt in as regular feet (because that’s what I have my units set to).

To verify missions I always write to the aircraft and then manually clear the mission on the mission planner. Upon reading the mission back the value of the 2nd box (Radius) has been changed from 300 (or any other number I have tried) to a value of 1.

Nothing I have tried changes this, I put in one number I get back 1 when I read the mission back.

Please advise on what this will do if I launch 8 hours from now.

I didn’t use the function today. Instead I will just update to 3.4 release and hope for the best.

There was a bug in LOITER_TO_ALT that has been fixed in 3.4. Please let us know how you go with 3.4 because if your still seeing the problem we need to fix it.

Thanks, Grant.