Loiter Oscilations and poor wind performance - Help with tuning quadcopter with 28" props

Hi, I have been attempting to tune a quadcopter with large props, but having problems with overshoot/oscilations in loiter mode, and instability in high wind. The quadcopter configuration is below:

All up weight: 10kg
Motor/ESC: TMotor U8 Lite 190kv / TMotor Alpha 60A LV
Propellor: 28x9.4 Folding propellor
Battery: 6s 22000mAh
Autopilot: Cube Orange on Kore Carrier Board

What I did:

  1. Calibrated ESCs and setup SPIN_ARM and SPIN_MIN parameters properly

  2. Followed all instructions in https://ardupilot.org/copter/docs/tuning-process-instructions.html to set up the parameters based on the prop size and battery voltage.

  3. Test flew the aircraft with stock PID’s, the aircraft felt loose on pitch and roll but not unstable

  4. Autotuned the aircraft on Roll, Pitch, and yaw. There were no problems in autotuning, felt pretty safe

  5. Flew the aircraft with the new gains, the aircraft feels better than the stock gains to fly in stabilize and althold, but in loiter mode, when coming to a rapid stop after moving fast, the aircraft builds up oscilations, which do settle down eventually but are very unnerving

  6. Flew the aircraft in 15 knots of wind (all previous was dead calm), in alt hold mode, the aircraft was rapidly blown to a 35 degrees angle (uncommanded), though it did later recover to flat and I was able to land it.

Settings I have changed since autotune in an attempt to improve performance:
Changed ATC_THR_MIX_MAN from 0.1 default to 0.5, this improved performance in alt hold, didnt seem to help in loiter.
Lowered loiter acceleration settings from the defaults to avoid the aircraft jerking on stopping. This helped slightly in loiter but there are still uncomfortable oscilations.

Two logs can be found at this dropbox link:

One is of flying hard in loiter flight mode, showing the oscilations that build up on hard stops.
Here is a screenshot from that log showing the uncommanded oscilations:

The second is of a short flight in 15 knots of wind where the aircraft immediatly became unstable.

Thanks in advance, I would be grateful for any help, and happy to try any settings suggest and provide any more logs that might be helpful to analyze!

What ESCs have you got?

The ESC’s are the TMotor Alpha 60A LV, ill edit my post to include

In the first log (Loiter) there’s no actual Loiter flight mode in there, It’s all Stabilize.

Roll response seems OK but pitch is not so good for some reason. All PWM (motor outputs) are even so there’s no great weight imbalance or frame twist. Maybe it was just wind.

As a matter of safety and urgency I would set these immediately. They should be mandatory for any aircraft with props bigger than about 6 inch.
You will have to stand around waiting for a good GPS 3D fix, but it gives you time to think and ensures you’ve got a valid home position for RTL.

You should set these for the ESC’s you’ve got, and a bit of tuning:

And your PIDs looked a bit low, but you might want to retest with the other settings first before changing them or running another Autotune. I’d be tempted to try something like this, a little higher on the P and I terms:
ATC_RAT_RLL_D,0.0045 (unchanged)
ATC_RAT_PIT_D,0.0045 (unchanged)

Looking at the log in windy conditions, the settings above would probably help, or at least be a start.
I’d suggest changing Flight modes to Stabilise, AltHold and Loiter for testing

1 Like

Thanks you very much for the suggestions! I will try these out tommorow!

Can you tell me anything about the use of ATC_THR_MIX_MAN?
I have seen some people recommend setting it to 0.9 for quads with large props, but am cautious to do so as I understand it could cause a flyaway if poorly tuned?

Regarding the loiter oscilation log, here is a screenshot from the log “loiter oscilations.log” showing more clearly what I mean. In this screenshot and in the log, a large pitch axis movement is commanded in loiter and then released suddenly, leading to overshoot and oscilation. (RCIN.C2 is my elevator channel)

I’ve had the exactly same oscilations…

I’d test with the suggested parameters first, then let’s see another .bin log

Hi Shawn, we went out and tested the settings you recommended and there was a significant improvement. We did one flight with the motor/pwm/esc settings you recommended, and then on the second flight we added the suggested PI gains. We saw an solid improvment with both changes.
There is much less oscilation on hard stops in loiter, the drone feels much less unstable and much more comfortable to fly. The wind was quite calm so we were not able to test the wind performance.

The dropbox link below has .bin log files for both flights. From looking at them myself I still see some overshoot when comparing PITCH to DESPITCH, so perhaps there is still improvement to be made?
Would appreciate your input!
By the way, the quadcopter is totally symetrical, so the inertia on roll and pitch should be quite similar.

Thanks again for your help!

Please set these, you wont regret it, even for testing. Even set a switch to Motor Emergency Stop during testing, RCx_OPTION,31
I’d hate to see one of these with big props heading off to the Sea of Japan…

You can set these:
And I’d move onto Harmonic Notch Filter config:
Then Autotune, maybe one axis at a time at first. After that’s done you can do an Autotune with all 3 axis at once since it will be quicker after the first round.

Here’s a outline of the Harmonic Notch Filter settings and the order you need them in. There’s a test flight and log-examinations between each phase, but follow the doco and these will make more sense:

HNOTCH phase 1

HNOTCH phase 2
INS_HNTCH_FREQ,peak freq from FFT
INS_HNTCH_BW,hover_freq / 2

HNOTCH phase 3

@xfacta thank you, will follow your advice and the harmonic notch filter docs to continue tuning this aircraft.
I am amazed at the effect the settings you recommended made on this aircraft already!

I also appreicate your advice regarding the failsafe/fence settings. I have configured these according to my organizations UAS operations policy which we follow on aircraft of all sizes. This said I will take your advice and setup an emergency stop switch during our testing.

Thanks again, I will report back with my progress!

Hi James, I also have problems with overshoot/oscillations in loiter mode and I followed the setting Shawn recommended to change some PID gains. It was going better right now. But I just wonder did you try Harmonic Notch Filter and the problem had been solved after that? Thank you!


I dont remember the specifics, but these changes helped, and the thing that made the most difference in the end was doing a manual tune on the aircraft, we never got acceptable results out of autotune.

@james33 hi, can you guide, how you have solved your issue ?

He fixed it by following the instructions. Please do not go on other threads. You have your own thread. We gave you instructions there already.

1 Like