Loiter mode shakes quad badly

I have tator frame ( not sure what ) hexacopter with pixhawk. 40A esc and 335kv motors and 2x 4s 5200mah batterys.
Im having few problems. I have 433mhz 915mzh tx that send info to my phone, phone has same rx. After im more than 10m away, phone tells me (signal lost) and I have no information anymore. antennas are correctly, and also I cannot see battery voltages from phone, Im using qgroundcontrol software.
Thats the first thing, not so important.

I have done 10min autotune but in loiter mode or poshold or althold, the quad wobbles around and if I dont change mode to stable, it will start wobblying so much that it crashes.
Even when there is no wind at all, the it is wobblying around, ( stays in one place and does not drift )
Im having good gps, and gps antenna is raised 20cm above the frame.
I have done compass calipration many times etc…
I fly alot fpv drones so im not new to drones, but new to ardupilot and hexacopters.

The wobblying comes from bad PID’s?
How to tune them manually? I have not found any intructions, everyone says “autotune” but its not doing anything (it changed PID’s from default so its changing, but does not affect flying)

Do I need to autotune IN loiter mode?
Because I tuned in alt hold.

Post some pictures of your hex and maybe we can identify it for you.

Give us a complete hardware list that includes the brand names and specifications for your motors, props, ESCs, radio gear (RC transmitter and receiver), telemetry radios, computer system and operating system (Windows, Mac OS, or Linux) Phone and operating system (Android, iOS)and so on. Add to that the All Up Weight (AUW) of the aircraft with everything installed including the flight battery.

Post one or two of the latest flight data logs.

Using the ArduPilot/Mission Planner documentation (which I prefer), you can use In Flight Tuning to get the Roll and Pitch PIDs tuned fairly easily.

For using AutoTune be sure to read the entire document and pay particular attention to all of the steps under Setup before flying…

After looking at your initial post again, I see you are using 335Kv motors on 4S. This could be the root of your problem.

I have a Tarot 680 Pro Hexacopter. The AUW is 3248 grams. I’m running 1355 carbon props with 740Kv motors on 2 5200mAh 4S LiPos in parallel for a combined capacity or 10400mAh. I also have a Tarot 650 Sport Quadcopter that is stretched to 665mm. AUW is 3245 grams. I’m running 1655 carbon props with 350Kv motors on 1 10000mAh 6S LiPo. The quad has a longer flight time (about 7 minutes longer) than the hex…

The point here is, on 4S a 335Kv motor will have a hard time of it. I’d wager the aircraft hovers well above 50% throttle, and that’s a bad thing.

Ideally you want the aircraft to hover at or slightly below 50% throttle. This gives you acceptable prop speed (and hence thrust) to keep the aircraft in the air with a sufficient amount of throttle head room for the flight controller to maintain stability.

An aircraft that hovers above 50% throttle is either over weight or underpowered. In this configuration the flight controller has less than an ideal amount of stability throttle head room. In an extreme case the aircraft may hover, but it will be difficult or impossible to fly safely.

HI. My quads howers in 35-40% throttle. I have no idea about the weight. but here are some better details.

How can I do flight data logs?

Im not sure about the frame, looks like Tarot 680
esc: hobbywing x-rotor 40A
Matex PDB
fpv model mc5008 335kv motors
carbon fiber 18" inch props (they are 46cm long, so 18inch?)
fs-i6b reciver
flysky i6 radio (updated to 10 channel)
and pixhawk with external compass/gps

PC is windows 8.1
and phone is Honor 8 with android and Qgroundcontrol software.

The auto tune did nothing, changed PIDs but still feels the same and wobbles around in alt hold or loiter…

It seems like when I fly in stable mode and I try to hover, there is no problems. as soon as I switch to loiter, althold or pos hold, It hold the place, but even little wind and it starts wobblying around.

Here is few pictures I found.

If you’re swinging 18" props, that frame is not a 680 Pro. The 680 Pro is limited to 13" max. Other clues are the mounting rails and the motor mounts. The rails are spaced much wider than a 680. The motor mounts look like they are for 25mm tubes. I’m thinking this is a Tarot T960.

To get the logs I use Mission Planner.

Downloading logs.

The files are time and date stamped, and come in two “flavors”, .log and .bin. The .log files are large CSV (comma separated value) formatted text files, so post the smaller .bin (binary) file.

For the AutoTune thing, did you let it finish and actually save the new PID settings as out lined in items 6 through 9 here, or did you have to bail out because the aircraft was becoming unstable during the process?

okei I’ll give logs tomorrow when I go to fly.
The autotune thing was very wierd, it never tuned pitch axis.
I did not have to bail from autotune (first in stable, then switched to autotune)
I flew in autotune almost 10minutes according to my phone, and it always did roll axis, never pitch.

There was no wind at all today so I went to fly

There you can download the .bin file from today.
(this forums upload thingy said too big file)

I have no idea how to read this myself so maybe you know what is happening.
Long story short.

I took off. changed to supeer simple mode because its easier to fly for me.
Then I tried to hover in stable mode and move around, everything was working.
changed to alt hold mode and no rc input, everything was fine.

I moved around littlebit and took some altitude. Then changed to RTL mode.
it came to home but when decreasing altitude, it started to wobblle around very much and I was 100% sure its gonne crash 20m above ground. I quicly changed to loiter mode, no effect, then to alt hold mode and I started to try to correct the wobble myself, I saved the quad but I was so scared that I forgot how to land and I wanted to give pich forward but did backwards and that why there is small crash at the end of the log.

Hopefully you can see what is wrong with it.

Confirmed, the frame is tarot 960

It hasn’t tuned.What you’ve got there is a big scary flying wobbly thing.Been there,done that,got the mental scars.

For copters with big props…

Set ATC_RAT_RLL_FILT, and ATC_RAT_PIT_FILT, to 10 (half the stock loadout value).
Set Autotune Aggression to 0.05.

Use Pos Hold to autotune and set it to 3 which should do Roll and Pitch.After it stops twitching switch back to Pos Hold and then to Autotune again, and then land and disarm.That’s how to save the values.Then do the Yaw AT.After that a couple more ATs with all three axis enabled should give you a nice stable copter.

This is my Tarot X6 swinging 18 inchers doing a Position Hold Autotune.So relaxing it’s not funny.It’s relaxing.:slightly_smiling_face:

what do you mean do autotune with all three axis?
how do I autotune yaw?

Pos hold and then autotune.

so basically, I do autotune many times?

I have a large twin battery set up and can tune all three axes in one flight,but only just for the first one which takes longest.It took around 18 minutes.If you don’t have that amount of flight capacity it’s best to tune the axes seperately.Or do two and then the third one after.The settings are in full parameters under autotune and are

  1. Roll
  2. Pitch
  3. Roll and Pitch.
  4. Yaw
  5. Roll and Yaw
  6. Pitch and Yaw
  7. Roll,Pitch and Yaw - in that order.

And yes,do a few tunes until you’re happy with it.I think I did three or four on this frame even though it was good after the first one.It did alter the PIDs a bit but not drastically.You may be happy with it after the first round.

Make sure to set those filter values beforehand.

Also,reset the ATC_RATE_RLL_P to 0.135.That’s stock and for some reason your’s is set to 1.0.All the others are stock.

what filters? :smiley: Sorry im noob.
how do I set filters in ardupilot.
I know this stuff on betaflight but this is new world for me.

the atc_rate_rll_p changed after the first autotune I did.
I also have 2x 5200mah batterys and the owner before me said stable flight gets something like 20minutes.
So I think I can do all in one flight?

under full parameters, I set autotune to roll, pitch and yaw.
That means autotune all three axis?

The ones posted above.

Set ATC_RAT_RLL_FILT, and ATC_RAT_PIT_FILT, to 10 (half the stock loadout value).
Set Autotune Aggression to 0.05.

All in Full Parameters.

Also,reset the ATC_RATE_RLL_P to 0.135 - You can do this in Extended Tuning or Full Parameters.Remember to WRITE (in the right hand column) after changing them if using full parameters.This is to reset a stock loadout for the autotune to start from.Try all three axes but an autotune uses a lot of power.Roll and Pitch would be safe to do together i would think but yaw may be pushing it for a first autotune.Future tunes should taker a lot less.My last one on the Tarot X6 took 6 minutes.The first one nearer twenty.

It will take a while before you get comfortable with all the 800 odd parameters.The devs add to them and change them a fair bit so it’s a constant learning curve for all of us.

can I autotune in super simple mode?
it would be easier to bring it back if it drifts away.

I don’t know.Never use simple mode.I’ve trained myself not to panic.Much.:slightly_smiling_face:

I’d say give it a go.Once it goes into autotune I never touch a gimbal.I just let it get on with it.The Position Hold is loose but keeps it in a small area.I never felt the need to interfere once.Try a few deep breaths as you switch into autotune.

I dont have camera yet setup so I fly line of sight and dont know which way is front if it yaws :slight_smile: so thats why I try to fly in simple mode.

That just takes a bit of training yourself.I always flew in stabilize and if I lost orientation I’d flip to Pos Hold and twitch the copter until I knew which way it was pointing.It’s useful skill to have and worth practicing for those times when it goes a bit wrong.Relying on Loiter or Pos Hold to do the work doesn’talways work and manual flying comes in handy.FPV helps a bucket load until it fails.:smiley:

Anyway.Set those filters like I showed you cna run a couple of autotunes.See if that gets it flying nicely.Flying a badly tuned copter can put you right off flying.

My fpv camera is atm on my fpv quad.
I still fly fpv everyday because its alot easier and much more fun :smiley:

I need to get something like gopro video transmitter so I can put my gopro on the gimbal and fly, then ofc I fly without stable mode or simple mode because I know where the quad is going.