Loiter mode doesn't work

Hi everyone,

I’m desperate trying to make loiter mode work correctly. I’ve tried everything. I’m using the APM 2.8 (the clone) with the last firmware version available for this board (3.2.1). Stabilise mode is working fine and Althold too.

Once I switch to Loiter mode the Copter flies away and it doesn’t respond to flight controller. I get between 7 and 10 satelites and around 1,5 HDOP. So I think GPS is working well. I’m using an external GPS + Compass module. I’m not sure about the behaviour of the compass. I’ve done the compass live calibration several times. It seems to point to the north. Also I’m not sure about the magnetic declination, I’ve tried manually and automatically with no success.

Could someone give some light in this issue?

I will really apreciate your help!

Thank you!

The best thing to do is turn up the logging on this unit and fly it and change to Loiter mode and then back and upload or create a link to the log file so we can see what the flight controller thinks.

I believe HDOP has to be below 1.4 before it will allow Loiter mode to work.


Are you sure you have the external compass facing forward? If it’s not oriented correctly, it gets ugly.

Thank you for your answers!

I’ll try to upload the log. I got the external GPS + Compass facing forward, at least the arrow outside, It would be very odd to face the arrow to other direction than the magnetometer inside.

Anyway, now I’m facing another problem apart from that. I’ve realised I was using the internal compass which could be influenced by some kind of magnetic interference. I forgot to take the jumper out. Once the jumper is out I’m using the external compass. I’ve calibrated again with the Live calibration but I’m getting "Setting new offsets for compass #1 failed” error. Also It seems to be reversed. When I turn right it face left in the map and viceversa.

Could you help me please?

Thanks in advance.

Check the compass pull down for your external compass. It should say None. It could also be that the compass is mounted upside down in the GPS. In which case you need to set Roll180 in the pull down.


FIXED for the moment! Thank you so much for your worthy time. Although when I try to calibrate the compass via the Live Calibration process I still get the error "Setting new offsets for compass #1 failed”, even though I tried Loiter mode and it’s working fine. Auto mode too.

Could it be a Mission Planner bug? I’m aware of similar problems solved by a new release.

So grateful for your help!