Loiter and auto takeoff

Hi all, I have been steadily practicing with my trex470 with AC3.6.0 for a while and have went from traditional UHF RX to the EZ-wifibroadcast and now I have settled on UAVcast. This system uses 4G LTE to communicate with a raspberry pi that then communicates directly to the pixhawk. My problem is that I can only use my taranis in joystick mode through qgroundcontrol and therefore I cant use the switches for any flight modes or throttle hold. I will attach some logs in which I try to execute several auto takeoffs as well as loiter takeoffs but I’m having a hard go at it. Without channel 8 control through a transmitter, I dont know how to start the motor, I have tried to set SERVO8_function to enable motor start but the craft will still not takeoff. With the taranis as well as the virtual joystick in qgroundcontrol I can move all the sevos on the ground in STABILIZE only, once I go to loiter mode on the ground, the only servo that moves is the rudder servo. Thank you for your help


My thoughts are that if I can figure out how to get the motor started without me being able to use a throttle hold switch that would be the first step.

The log shows ERR: FLIGHT MODE - 4, but I don’t see what error code 4 is supposed to mean in the definitions, so I’m not sure what it’s unhappy about.

It might be worth taking a step back and seeing if it is possible to get your switches working with the joystick. I haven’t done that myself, but surely it must be possible. What exactly is the limitation with the virtual joystick that prevents you from using more channels?

Whenever I plug the Taranis in it shows channels 0-7 but none of them can be used for flight modes or switching channel 8. When I plug the Xbox controller in it shows four flight axis but all the rest of the buttons say they are for “firmware use only” and are unassignable. I’ve read elsewhere that this has something to do with copter firmware but that’s all I could find so far

I finally settled for reinstalling my frsky receiver and initiatiating the takeoff then I shut my Taranis down and continue the flight from an internet connected laptop for auto missions.

Hi, I have not done what you are asking with an actual helicopter but I have done this using SITL connected to realflight. However I use mission planner rather than qgroundcontrol. Mission planner allows me to configure the controller and have a switch on my controller be mapped to channel 8 for motor interlock and channel 5 for flight modes. I don’t know if this is possible in qgroundcontrol.

I will say that it is not recommended that you fly through the joystick controller connected to a ground station. The update rates are typically slow, especially using a Sik radio, and not conducive to flying the aircraft in manual flight modes like stabilize. It may be acceptable with a UDP connection as that is how I am connected to the realflight aircraft using SITL.

I hope this helps.