Loiter altitude/instability issues in wind

I just recently changed my rig a little (dropped the beaver tail/battery location, front mounted gimbal, and added legs, 11" x 4.7 props and 3 axis gimbal). Since changing this, my quad has been very unstable and eradic…

My 3 modes programmed are Alt Hold, Loiter, Waypoint, but I’ve done some data logging and Auto-Trim in Stabilize. Stabilize is fine. When I switch over to Alt-Hold or Loiter, it hovers just fine, but when the wind picks up, it starts to rock and swirl and will drop altitude. If I do nothing, it will come down and smack the ground. Basically, in order to save it, I have no choice but to throttle up.

Props are balanced, again, and again… Rig went from incredibly stable and predictable to really worried about letting this fly.

I also noticed after performing the Auto-Trim, it messed with my Artificial Horizon in MP, but after doing an Accelerometer Calibration, that was fixed. Well then the Accelerometer Calibration ruined my Auto-Trim I just performed. After researching, I guess it’s better to arm a switch as CH. 7/8 and then activate while you’re already in the air? Will be doing that shortly. I’ve also been told to try Auto-Trim… I don’t think this will resolve my issues though.

Has anyone ever experienced this/fixed it? Any input would be appreciated as there are a few of us with Steadidrone’s/APM that have gone this route (legs/gimbal) and are experiencing the same things… The guys Running Steadidrone’s/Naza aren’t having any issues

How about providing either tlogs and/or data flash logs to help troubleshoot your issue.

I will try and get that up ASAP. Anything specific to upload it?

You can use the tlog and data flash tabs under the HUD in the MP Mission Data Window.

Tried that, but it says it can’t get slog list from Mavlink… I’m connected, and downloaded the logs from the terminal. But they’re in a .kmz, .log, .gpx file types…

Well looks like the .log file is gonna upload. Here it is. Approx 15 minute flight.

In case that log didn’t post, here it is again.

Screen capture of my LogAnalyzer

Well I tried uploading my logs/post, but it doesn’t seem to have come through, and until i have 10 posts, every post has to be approved… On vacation for a few days, if it still doesn’t come through, I’ll try again tonight at the hotel. Thanks guys!

Any ideas?

Sounds like you have to change the PIDs if you have changed so much.

Did I get it right you have moved CG forward much after not having your batteries aft anf also front loaded gimbal? Remember there are separate PIDs for loiter…

Sent using Tapatalk