Log Download

Since the last few updates I have not been able to download log files by wireless or cable.

I have the HobbyKing Pixhawk.

I can connect APM 2.0 latest version by either method and retrieve log files without a hitch everytime. But with Mission Planner I get an error.

please post the error.

The error is simply “Error receiving log list”. If I disconnect shut MP and open APM 2.0 and connect I can see and download all log files. This is with the same cable and computer the only difference is the software.

could you please post the tlog? this should show me why its failing.

This was the last time I flew. If you need anything specific just ask.

Seems I can’t add a log file… so here it is to download.


This second one is from today including data log the flight ended in a crash for some reason but at the end I tried to get to the logs before I turned it off.



im not sure why, but the reason for the fails are timeouts

it takes almost 10 seconds for the pixhawk to respond, do you have your data rates in MP set high?

ive looked more, and its not a data rate issue, i think there maybe something wrong with your microsd card.

Ok yes you where right. I formatted the microsd card and I can now see and download in MP… I should have tried that but because APM could read it I assumed it was something else.

My little crash was weird it looks like the battery just drops off to 9v or so before I hit Land and got it down.

Thanks very much for you help that had been annoying me for ages.