Log Analysis

I’ve just signed up in the forum in the hope that someone will assist me with looking at the datalog of my last fatal flight! my quad has been flying nicely for a while now. I recently upgraded to 3.1 RC5, the first few flights seems rock solid, but suddenly today the quad pitch forward 90% while it was in a stable hover and flew off in the distance and crashed. I tried pulling back pitch but there was no response. I suspect the front right esc failed, but the quad didn’t roll at all, just a perfect forward pitch.
I have attached the datalog, I would really appreciate a little help with analyzing.


I’m terribly sorry, I approved this post and disapproved the other one as a duplicate, but it appears your attachment didn’t get posted with this one. I tried to grab it from the other and am unable, would you mind re-posting that log?

Thanks, and sorry again!

Hi Josh

Thanks for your message,

I have found the problem, must have been the front right ESC as I replaced it and it seems fine now. Strange thing is that the copter didn’t roll, perfect pitch forward. I would have thought there’d be a dip only on the right front side?
I have also downgraded to 3.0.1 from 3.1 RC5, although I think the quad flew much better on RC5, I’d rather just wait for the official release.

Thanks for approving me! Oh and sorry I double posted, thought I had done something wrong with the first post, but then realised it needs to be approved!!


No problem at all, glad you got it sorted :slight_smile:

@sveness now you have had two posts approved your posts no longer need moderation.



Thanks Chaps :smiley: