Log analysis help please

First flight on new pixhawk on f550 hexa. All other pixhawk experience on fixed wing (APM PLANE).

Took off, hovered. Descended to a lower alt and tested flight direction (forward, back, left right). Climbed 10 feet or so and hovered for a little bit. All of a sudden without any throttle change on RC the vehicle dropped very fast (motors running, but slow) to the ground. I then tried to lift off again and it started to tip, tried to disarm (throttle low rudder left) and it kept running (almost on it’s side) eventually flipped over and motors stopped.

You can see that the altitude and desired altitude and throttle don’t correlate. Just not sure what else to look at in the logs to see where my issue may be so I can address and re-test.

Thanks in advance for the help.


Any help here?

performed accel calibration and compass calibration again and tried again.

Was getting BAD GYRO HEALTH before calibration and after the message was gone, and copter would arm.

Flys fin in stabilize mode, but when switched into loiter it wants to drop out of the sky, then when on ground it slowly increases 1 side till the copter goes on its side, then eventually over. Switching back to stabilize mode give me control back. When in loiter I can also not disarm (lower left throttle stick) but in stabilize I can.

During this also the BAD GYRO HEALTH message returned.

Does this help with the log analysis? Sounds like I may have a compass/gps problem?


Not able to determine what happened from the log. It looks like some magnetic interference happened at the time Throttle out started to go down. This however did not effect the yaw.
I do know you need a good compass to fly in Loiter mode.

I would try a test flight in Stabilize and Altitude hold mode and post that log so we can see what’s going on. You may have a bad flight controller.


Here is the log from the 2nd flight discussed. You will see, flys normally in loiter for a little while and then drops and tries to flip when on ground… then when switched into stabalize mode it’s fine.

Any way to tell if it is an issue with the onboard compass or the external compass in the GPS antenna unit?

Here is the auto analysis… same erros as the 1st… complains about compass and slow loops… indicitative of hardware failure? This is my 4th pixhawk, and would be the 3rd bad one ive had to send back if so… not confidence building!! =\

Log File C:/Users/s97848/AppData/Local/Temp/tmp5FAC.tmp.log
Size (kb) 5628.123046875
No of lines 75302
Duration 0:06:39
Vehicletype ArduCopter
Firmware Version V3.2.1
Firmware Hash 36b405fb
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = UNKNOWN - No ATUN log data
Test: Balance/Twist = GOOD -
Test: Brownout = GOOD -
Test: Compass = FAIL - Large change in mag_field (50.24%)
Max mag field length (693.56) > recommended (550.00)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = GOOD -
Test: GPS = GOOD -
Test: IMU Mismatch = GOOD - (Mismatch: 0.65, WARN: 0.75, FAIL: 1.50)
Test: Parameters = GOOD -
Test: PM = FAIL - 31 slow loop lines found, max 11.18% on line 1487
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = GOOD -

Why does MAGX on 1 compass look almost identical to MAGZ on the other compass?

Is something flipped?

Based on what the logs show, does it look like interference? I moved the GPS to the other side of the vehicle and up about 3 more CM and it seems to do much better.