Loading Firmware error 203

hi @rmackay9
I followed the tutorial on loading the firmware

I chose hexa type
but he shows me this error


please how can I load the firmware !!!:confounded:

Hi @Anna_SPARKS,
there were some changes in the firmware so we had to adjust the upload dialog. You will have to update to the last release canditate 2.0.26-rc2 to make things work.
Usually you can find the newest APM Planner here: http://firmware.ardupilot.org/Tools/APMPlanner/beta/ but the rc2 is brandnew and therefore you can find the linux and windows versions only here: https://www.dropbox.com/sh/pqd66ncnqw7km2b/AAAyCbYSaqanXIhckVNOeIzra?dl=0 at the moment.
There you should look for something named apm_planner_2.0.26-rc2…


thank you @Arne-W :wink:

Hi all,
i have (had) same problem. Thanks for hint to new rc2 brandnew version. I am now one step further, But next problem with flashing.

Download seemed to be finished but flashing will not start.

Ahhh…Some weeks ago, everything was fine.
Do you have an idea ?


Hi @Andreas_Schmidt,
one step further is the right direction :wink:
The APM Planner creates a log - I am not sure where you can find it on Windows… It must be somewhere in the AppData folder. If you can not find it you should find some sort of Debug console in the help or info menu in the menubar.
Perhaps you can find some more information about what went wrong. You can post your log here and I will haev a look.
@Anna_SPARKS Did the flashing work for you?

1 Like

yes the flashing works
but I had a problem installing a GPS + compass 3dr

if you have an idea it will be a great pleasure :smiley:

Hi, I have the same problem as described by Andreas. Under Ubuntu 18.10. It has worked great before. But now it only downloads the firmware, and doesn’t install. For a custom firmware, the process doesn’t start at all. For windows on VirtualBox, and MissionPlanner it works fine. Help :slight_smile:

@maciek252 As the downloading woks I assume you are using APM-Planner 2.0.26-rc2 already. I tried flashing new FW with that version some days ago on an Ubuntu 16.04 and it worked.
Nevertheless the the apm planner should generate a log file. It can be found in the apmplanner2 folder in your home directory. There should be one log per day and only 5 logs are kept older ones are deleted.
It would be cool if you could upload a log - I will have a look.

Yes, I’m using 2.0.26-rc2. I can connect but I can’t upload the firmware. Flashing works fine in QGroundStation under linux, by the way.

I attach the log.apmlog_20180706.txt (11.7 KB)

The problem seems to be this:
[20180706 13:06:58.497 INFO ] - Port found! “ttyACM3”
[20180706 13:06:58.501 ERROR] - Unable to open port: “Permission denied”
[20180706 13:06:58.501 WARN ] - QIODevice::write (QSerialPort): device not open

Of course, the serial port is working from other programs (no group dialout membership problem).

Hmm strange - this is from Qt documentation:

QSerialPort::PermissionError: An error occurred while attempting to open an already opened device by another process or a user not having enough permission and credentials to open.

Could you try running the planner with sudo just to rule out a problem with your permissions?!

@maciek252 Have you seen my question?