Servers by jDrones

Loading custom firmware for chibios is not working


(wkf94025) #1

I have built chibios-based ArduPlane for Revo-Mini, under BASH/Ubuntu/WSL. I have flashed the revo405_bl.bin bootloader, per Randy’s porting to Chibios documenation. I am running last version of MP, and when I go to load custom firmware, it will reboot the RevoMini, but it doesn’t seem to come back up in bootloader mode. Eventually MP times out. What is wrong between MP and and the _bl.bin? It works maybe 1 in 10 or 1 in 20 times. And with the com port scan/timeout, it’s not a fast failure. I’m lost with what to do from here. I have a nice fast compilation setup under Ubuntu/WSL, but can’t seem to find a reliable way of flashing new firmware on the RevoMini. If I flash the F4Light firmware using only dfu-util, it’s quick and predictable. I’d like to get to that same place with Chibios Arduplane.

Kelly


(Michael Oborne) #2

please use beta MP. last release version does not detect these boards with the new bootloader


(wkf94025) #3

I tried to download beta MP, and ran into some error messages and failure:

Move: C:\Program Files (x86)\Mission Planner\AltitudeAngelWings.pdb.new TO C:\Program Files (x86)\Mission Planner\AltitudeAngelWings.pdb Done.
         file: C:\Program Files (x86)\Mission Planner\BSE.Windows.Forms.dll.new
Move: C:\Program Files (x86)\Mission Planner\BSE.Windows.Forms.dll.new TO C:\Program Files (x86)\Mission Planner\BSE.Windows.Forms.dll Done.
         file: C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new
Move: C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new TO C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dllC:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new Failed.
Move: C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new TO C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dllC:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new Failed.
Move: C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new TO C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dllC:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new Failed.
Move: C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new TO C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dllC:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new Failed.
Move: C:\Program Files (x86)\Mission Planner\GMap.NET.WindowsForms.dll.new TO C:\Program Files (x86)\Mission 
...
Move: C:\Program Files (x86)\Mission Planner\ZedGraph.pdb.new TO C:\Program Files (x86)\Mission Planner\ZedGraph.pdb Done.
**Update failed, please try it later**.
Press any key to continue.

(wkf94025) #4

Just tried beta install now, and similar series of error messages, and failure at end. banner at top of window says Mission Planner 1.3.56 build 1.3.6699.7110

Kelly


(Michael Oborne) #5

the update failure is because MP is still open somewhere


(Michael Oborne) #6

can you post the missionplanner.log file for the update process that is failing?


(Michael Oborne) #7

also what OS are you using?


(wkf94025) #8

Using Windows 10. Can you confirm that using the get beta updates from the help window is how I should access the latest MP beta that you are referring to? I can post logs later today or tomorrow. Thanks for your attention to this matter.

Kelly


(wkf94025) #9

Can you clarify which log file(s) you’re interested in? I see a bunch of files named MissionPlanner.log. in C:\ProgramData\Mission Planner. Is that what you’re after? Or is it the directory in my user area as specified in MP’s Config/Tuning -> Planner -> Log Path ?

Kelly