Servers by jDrones

Loading Custom Firmware Error


(David Ardis) #1

When I try and load arducopter 3-6-RC4 ChibiOS with the latest download of Mission Planner and get the following error

Mission Planner Version 1.3.56 build 1.3.6672.30243

image


(Dave) #2

Install the latest Beta version of Mission Planner.


(David Ardis) #3

I have done that then uninsulated and installed latest version with no success


(Dave) #4

Hmm. I had that same error with a particular version of beta. The next rev fixed it. Post in the MP thread maybe get better results. Or just use QGC to get it loaded, it rarely fails.


(brandon macdougall) #5

What I did was to download the MP. zip in a clean directory like c: then made one more to install like in Desktop
then updated MP beta. this give you a clean version and the beta version…


(David Ardis) #6

@Michael_Oborne is looking at the problem
https://discuss.ardupilot.org/t/loading-firmware-error/30654/3?u=ardisd


(Michael Oborne) #7

the issue is dll’s from the older install that are no longer used, but linked into the newer version


(Paul Atherton) #8

I had exactly this issue Michael, and resolved it by removing .NET from Windows 10 completely.

Prior to this I did uninstall MP (completely, even removing left behind folders and reg entries), and re-installed from scratch without any improvement. It appears that the Custom firmware flasher was finding a different version of the DotNetZip library in the C:\Windows\Assembly path before the one Mission Planner needs to use.


Loading Firmware Error