Servers by jDrones

Load orthomosaic images from DroneDeploy

DroneDeploy exports orthomosaic images containing high-resolution ground imagery and elevation data (e.g. height of trees). How can I load these images into Mission Planner? When I place the .TIF file in the srtm directory, the console shows many warnings and errors, but mostly “Can not read scanlines from a tiled image.” I would appreciate a guide to converting this file into something that Mission Planner will read.

are you using for DTM/elevation data or for photos?

DTM/elevation data. I fly 10 feet above the tree canopy, need excellent accuracy when flying over uneven tree tops.

@Michael_Oborne, any thoughts on using DroneDeploy imagery as the Custom base map for a Flight Plan in Mission Planner?

its possible now. would need to use GDAL to bring the image in.

what format is the image atm?

Link to the map file is here

Thanks for the image.

Currently MP can load 8bit geotiff’s the one you linked is a 32bit image, and does not display correctly.

if you convert it to a 8bit geotiff, you can use it now inside MP

  1. place the 8bit geotiff inside a folder
  2. open MP
  3. control-f
  4. custom gdal
  5. browse to the folder you put your 8bit geotiff
  6. wait
  7. goto flight planner
  8. change the map source to GDAL custom
  9. zoom to the area the image is located.
  10. enjoy
1 Like

32bit geotiff working

2 Likes

Thank you Michael! The process to load the GeoTiff worked exactly as you described. Latitude and longitude are showing up perfectly; however, unlike your example, my elevation reads “GeoTiff 0.00m”. The file is color-coded to represent elevations, with resolution down to the height of individual trees. Is the numeric data that was used to create this coloring available from this file, and can it be displayed by MP?

Note that my build is 1.3.7277.34800.

remove the geotif from the srtm directory.
C:\ProgramData\Mission Planner\srtm

there are different types of geotiffs. some provide rgb data like yours, other provide elevation data.
elevation data geotiffs go in
C:\ProgramData\Mission Planner\srtm

rgb geotiffs you can load via this method.

also i pushed a new beta MP earlier that includes the 32bit support

1 Like

Thank you Michael, I really appreciate your followup on this question. I will work with DroneDeploy to see if I can obtain a GeoTiff with the elevation data. If there is a technical term for that type of GeoTiff file, please let me know so I can ask for the right thing. I will also pull your updated beta.

@Michael_Oborne - After a long exchange with DroneDeploy, I have generated a GeoTiff and what DroneDeploy calls a DEMTiff file for review. DroneDeploy says that both files are “single image”, not “tiled”. GDAL2XYZ confirms that actual elevation numbers are present in the interior areas of the DEM file (i.e. portions of the area inside the roads) and also confirms they are not present in the GeoTiff file. I used the Beta button in MP to download build 1.3.7342.7306. I load the DEM file into the srtm directory and restart MP. MP still will not display the altitude of points within that field. MP console also still displays many errors - “can not read scanlines from a tiled image” when the cursor is first tracked over the area covered by my DEM file. This Log file shows (about mid-way) console output from that action.

The Custom GDAL process above properly displays the GeoTiff map images, but the altitude still displays either SRTM values (if no files loaded in srtm dir) or “GeoTiff 0.00” (if DEM loaded in srtm dir). So the graphic display portion of the problem appears to be resolved, but I am still unable to use the DEM file to display altitudes.

I feel like we’re close to the solution - can you help me get over the finish line?

i got it working, however the heights are based around 0, not ground level of 40m. the geotiff needs to be fixed to have the correct ground altitude

Fantastic news, thank you! How do I replicate this result? I ran the Beta Updates routine from the Help screen again, but the process completed and left me on version 1.3.7342.7306. After getting any updates, I restarted MP and got the same errors on my system that I described earlier. Your screenshot shows a later version… is it available for my use?

If I may ask, what was the issue? Also, do you know where I can find a description of this DemTiff binary file’s format? It does not appear to be available from DroneDeploy, but obviously you have found (or created) a tool that can read the elevations and place them correctly on the map.

Recalibrated DEMTiff file can be found here

Try mp master.
Hold control key and click beta update

1 Like

I don’t think I quite caught up to your version with that update. Holding Ctrl while clicking the Beta Update button on the help screen installed new build 1.3.7345.39688, and unfortunately this version does not include your new fix to this issue and behaves as my previous version did. Your screenshot above shows 1.3.7347.21071. Any suggestions to get me up to your fixed version?

Also, I remain highly interested in a description of this DemTiff binary file’s format? It does not appear to be available from DroneDeploy, but obviously you have found (or created) a tool that can read the elevations and place them correctly on the map. I’d appreciate any pointers you can offer.

I used Ctrl-Beta again today and was delighted to see a new update 1.3.7348.21187 that is working correctly! Thank you Michael, I really appreciate your time and interest in solving this issue!

glad to hear its working for you

3 Likes
Servers by jDrones