Link 1 down while connecting Orange PI to Pixhawk

Hi everyone, I’m trying to connect my Orange PI 3 to Pixhawk with telemetry. I make the connection below:

I also enable the uart from the config file according to user mauel of the Orange PI and my UART3 port is active:

When I run “” in the command line I’m getting the output below:

Auto-detected serial ports are:

Those ports are exist but only the ttyS0 and ttyS3 active.

My connections are true, I even tried to switch TX and RX, I also tried different baud rates (57600, 921600) but whatever combination I tried, I always get the MAV> link 1 down output from the mavproxy.

Can you help me out please? Am I missing something. I can connect raspberry to the pixhawk with same configuration.

Note: I completed all the steps in the links below

Edit: I also tried to connect it with USB-UART but same thing happened.

Usually USB connection runs at 115200 baud

I tried it now but unfortunately it did not work.

Also I tried to test my RX and TX ports with short curcuiting each other according to user manuel and they are working correctly. Bu still no link to pixhawk/ardupilot.

As usual, when you work with serial devices, you need to start from the known to the unknown

Install a simple terminal emulation software like MINICOM and connect ttyS3 to your PC using a USB to Serial FTDI converter. Then using Putty , or any other PC based terminal, establish communiction with the OrangePi.

Once that is working, try connecting to the Flight Controller still using MINICOM to confirm you receive data (Mavlink is not clear text type, so this is normal you see garbled messages), if that works, then you can try connecting using mavproxy or others messages handlers.

1 Like


Thank you for the comment. I just connected the Orange and my PC. I configurated the minicom and I can send my keyboard clicks from the PC to Orange PI. But it sends gibberish when I write something from the Orange PI.

So, I reverted the cables. Instead of “RX → TX, TX->RX” connection, I made “RX → RX, TX->TX” and this time when I write from my PC it’s gibberish. But when I write from my Orange PI it’s normal. I change the character tx delay to 1, and I also tried different Bits (9600, 115200) but it’s same.

What do you think causes this?

(I use the sources below for making this if anyone wondering

UART communication between PC and RPi using minicom - YouTube )

Have you connected ground from Orange to FTDI ?
Anyway, your problem is now clearly identified, you have the tools to fix it

1 Like

You are right.

Yes I connected the ground.