Limits on P I values copter v3.5.3

Why are there lower limits on all P values? I need to go to 0.02 on roll/pitch to stablize my racer.

Anyone with any ideas on how to go below that limit? Or how can I modified the code to get it done?
Many thanks.

I think in Full Parameter List you should just type the value and it will take it with a notification that it is out of range.

Or just use any GCS for grown ups… MAVProxy , Qgroundcontrol or APMPlanner2 :slight_smile:

Is this actually good advice?
I seem to remember trying things w/ other ground stations, and asking for help, and the answer was always to go back to Mission Planner when working w/ Ardu____. QGC when I put PX4 on the copter. (This was years ago, so maybe things have changed?)
If they all actually fully support all the new beta developments in close to real time, I’d definitely like to try some other ground stations.

most of all, you need something that lets you set parameters as needed, and using full parameter list, or terminal input in mavproxy, will do just that. You can combine MAVproxy with any other GCS you like, then enter “param set ATC_RAT_RLL_P 0.0002” if you like :slight_smile:

I’ve tried that. However the out-of-range value will be replaced by 0.08, which is the lower bound, once I unplug it and power it on again.

I will give it a try, as a grown up:laughing:

For me, I can always set any value I want in the full parameter list in Mission Planner.
I can’t imagine why it wouldn’t be working for you.
You cannot set them from the extended tuning screen or anywhere else. But the Full Parameter List always works.
Make sure your copy of MP is fully up to date.

Edited to say, I just loaded up MP and tested it, and was able to change it to .01, save, reboot, it worked.
Are you pressing “write parameters” after you make the change?

I’m using MP1.3.50 and Copter V3.5.3. I pressed write parameters. I can set values to 0 on V3.2.1. But not on V3.5.3.
If you are also using V3.5.3, do you mind trying to set rate roll P to values below 0.08 and see if it works? In the options column of ATC_RAT_RLL_P, do you also have (0.08 0.30) ?

I am on the newest default version… Not beta. I believe that’s 3.5.3, but am not positive. (sorry, I don’t have my copter/ground station laptop in front of me right now).

Earlier I did change the rate P values, and they did alow me to save below .08. I saved w/ .01 and it remembered them. And yes, it does say the limits are .08-.30.

From what I’ve tried so far. The value will be remebered until you power it off. When the fc is plugged in next time, the value should have been set back.
I’ve been reading through the change history of Copter this afternoon, and didn’t find any words on setting a lower limit on control parameters.
I guess I’ll start diving into the codes (something I always want to do) to find a solution.

I did power it off, then plugged it back in, and it was still .01.
All of us using small sub 250mm copters have to use values way lower than the suggested limits. We’re all successfully doing it.

Sorry I can’t help any further.

Thank you for all the details.

Maybe there’s just an issue w/ your saved parameters…
Try saving your config. Then reset the parameters to default. Then try changing it?

There’s a button on the full config screen to reset all the parameters.
Or in the past it was suggested to load a different firmware, like arduplane, then go back to arducopter as a way to clear some issues.

I will try that.
By the way, are you involved in ardupilot developing? After recent days of using ardupilot, I really want to get involved in the community.

I’m not a dev… I’ve just been using it for the past few years and reading this and a few other related forums daily.
I might have a better answer for you if I were a dev… But I can offer what I’ve learned from experience. :slight_smile:

It’s working now! I tried loading some preset and reset to default. And it worked!
Thanks for sharing your valuable experience. I believe sharing is also part of what keeps this community running.

The BEST way to get involved with ArduPilot development is to start compiling the code yourself, then playing around with it. Some good reading here:
If you’re already competent in C++, perhaps pick something that interests you from the issues list
and have a go solving/implementing it.
@OXINARF can give you pointers about making good pull requests, and code style etc.


It’s all in the developer wiki, the main points being at

We are also always available to help with developer issues in our Gitter chat: (I re-enforce this is for developer talk, not for users).