Servers by jDrones

LightWare SF11/C

Hy @ all,

I have a F450 Frame with a new Pixhawk 2.1.
I have installed a Lightware SF11 rangefinder connected over telemetry 2 port ( serial ).
When i switch to altitude hold the copter does not stay on a certain height. Maybe for a few seconds but then it starts to change for about 40 to 50 cm and goes back on the height i selected altitude hold. When i watch the video on the ardupilot wiki webpage it is much more stable. i have tried different selections on the sensor but with no effect. Maybe some of you guys can share the settings with me ??? I’m new to this and i have lots to learn…

Thanks in advance…

Jan

I don’t have my Pixhawk 2.1 yet…
But on Pixhawk, first, make sure the precision landing isn’t on through mission planner. This does wacky things to mine - and I don’t believe it’s supported for that anyway.

This behavior used to occur if the Terrain Follow option was enabled, and craft height would change as the terrain below got higher. I think it’s the setting under WPNAV - WP_RFND_USE - set to disable.

Download the Lightware terminal (if you haven’t already).
SF11/C Manual

If you’ve messed with setting on the lidar itself - reset them. Unless you’re using this on an analog input which you aren’t if you’re connect to serial, they don’t have any effect that I’ve seen (most are ANALOG-this and that)
The only one I’ve ever changed is the Zero Datum Offset - and you WANT to change this. Measure the distance from ground to the face of the Lidar in CM, plug this value into the onboard lidar setup menu.

In mission planner, set the following:
RNGFND_TYPE: 8
RNGFND_PIN: -1
RNGFND_SCALING: Don’t Change this
RNGFND_OFFSET: leave at default
RNGFND_FUNCTION: Leave as is should be linear
RNGFND_MIN_CM: I set this to 1
RNGFND_MAX_CM: I set this to 12000
RNGFND_STOP_PIN: -1
RNGFND_SETTLE: leave at default
RNGFND_RMETRIC: 0
RNGFND_PWRRNG: 0
RNGFND_GNDCLEAR: 0 (the zero datum offset sends 0 altitude when you’re at the measured distance to ground)
RNGFND_GAIN: I would leave this at default. If you’re still having issues, you can try to bump it .4 either way…but high settings mess with mine.

I wouldn’t suggest messing with any of the x y z orientations stuff.

Try this out and see. Also make sure you have stable 5V power going to it. Hope it helps.

In your full parameter tree, did you set up Serial 2 to 19200 bauds (19) and Function to 9 (Lidar serial) ? I know a guy who had the same issue than you and his serial was on 57600 bauds…
Do you see your sonar range (in MP) oscillating a lot ? ± 50 cm ?
You can check the raw data with the Lightware terminal and see if you have consitent data (distance, and % of confidence).

Starting from 3.5rc1 you can use SF11 with I2C so you might want to check if you get the same problem.

I connected in analog port as lightware reccomend me in a pix 1 and no problem, very stable.

I have PH2 and have set the Lightware SF11c RNGFND_GNDCLEAR to 31cm since that is the how far it is off the ground. (Large Copter) I get a .66 reading when on the ground. I would expect 0.00 It is connected to GPS 2 (Serial 4) Any thoughts on what I’m missing?

Did you try to set it to -31cm? (or rather -35cm)

Servers by jDrones