Lightware SF11/C appears to stop working with 3.4 rc1

Like the subject says.

I’ve got several different ways of providing stable 5vdc so it’s not a voltage issue. Tried 5vd from power module, bec, from the serial port, from the i2c port (in case i2c doesn’t supply enough current) and nada.
Changed the I2C address to 102 (0x66) as I saw part of the latest firmware (which I can’t seem to find ANYWHERE) has changed this to be the default address to help with Pixhawk compatibility.
After hours of jacking with it, I reconfigured to use serial again - nothing.

Crazy thing is, it actually started doing something on I2C at one point, but it was showing that I was 4-500 meters high while sitting on the ground. After a power cycle, it never showed up again.

All I get is bad LIDAR Health or Check LIDAR messages. Nothing on Quick hud…sonarrange or sonarvoltage.

Anyway…reloaded 3.3.3 and all is well - on serial of course.

I didn’t stop to think though…I’m using the Craft & Theory firmware which he compiles himself, to include his stuff…I guess this could be it, and maybe I should try the official build. I haven’t looked at it, but I can’t imagine what he’s adding in could affect this system…Thoughts?


Try the official build and let us know. We obviously can’t support firmware built by others.

Was actually in the process of doing this when I checked my email…because I’m crazy like this…I hate not troubleshooting something fully and properly.

I loaded the official build and rebooted. Was connected via serial at first.
It actually was reading, but it seemed off - and the error messages were there from first boot - bad lidar health etc.

But when looking at it…the “sonarrage” value actually reads properly. The quick hud “altitude” value is of while sitting on the ground. I couldn’t find a correlation or a specific value in which its off.

If you wind up looking at these logs, I lift the craft and turn 90 degs on the Z/roll axis, and then start panning around. The sonarrange value appears to be accurate up to at least 200’, but it appears the fc is not using that value on the hud as it showed only the vertical height at which I was holding the craft, I assume due to the error and it’s not using the rangefinder.

I then reconfigured and connected via i2c…and it’s pretty much the same thing. It did actually initially come up, and was reading correctly.
Pretty much the same thing as connected serial…“sonnarange” value appears correct, but hud isn’t the same value/or not using this value.

I also recently got an optical flow sensor. I thought I’d disconnect it to see if it was affecting it somehow.
This wound up screwing everything up because the i2c connected lidar no longer read on the “sonarrange” value, and i was unable to get it back after reconnecting the flow sensor.

After reconnecting to the serial, I was able to get readings again, as described in the first portion of this post.

It also appears that my time isn’t updating via GPS (/dataflash dirs dated 1999)

I’m using a Holybro brand pixhawk clone as shown here - Holybro Pixhawk
I’ve had zero issues with this fc since the day I received it.
Rangefinder is Lightware SF11/C fw v1.2 - settings: Serial 2 57600 / 9 (Lidar) ; rngfnd 1:address (when i2c) 102 / min cm = 1 max = 9000 groundclr = 0 (this unit has offset built in…it is set at the height it sits off ground - but I also tried without this enabled) scaling = 1 (tried this with multiple values as well) linear setting.

Tried to include as much info as I could. I’ve uploaded dataflash logs to the following link…both bin and log.


Did you try analog connection? I’m using that and no issues but with 3.3

I’d thought about that, but I could swear I read somewhere that noise is an issue with analog/adc.

In the end I guess…the point is to report the issue. And I’d rather have the thing on i2c if possible just for the less hassle of it all - an possibly fixed (if it’s a code issue and not something I’m doing wrong) for the next release.

I may give it a shot later though. Right now I’m gonna reload 3.3.3 and take her up for a few.

Analog is the recommended choice from Lightware, if you can’t solve your issue, take in consideration, here my test with analog

I don’t really feel like it’s an issue on my end that needs to be solved at this point. Like I said it works fine on 3.3.3…even adjusts it’s height over obstructions etc. Which was quite an experience first time it happened.
I’m really just reporting an issue I’ve come across with pre-release fw.

Don’t wanna stray from the subject too much, but,if you read their Arduino connection recommendation - “For highest accuracy, the serial port connection works best”. I’m pretty sure serial would be faster as there’s no ADC conversion time and probably less overhead on the controller…I’d figure i2c would be even faster but maybe it’s more prone to error. Don’t get me to lyin though…I’m no engineer nor am I a coder.
I’m also somewhere in the neighborhood of 15-17" from the connection so I’d rather not rely on a voltage reading which may be affected by voltage drop or who knows what.

But that’s the thing with most all of these types of devices…very capable devices but very little real world (i.e. end user) testing, and more than that…very little documentation from the mfg like “what’s the best way to connect to my XXX device that you’re selling compatibility with”, or “what are the correct settings with YYY device”. Or even “in our testing…we’ve found the following to work well with this system”

Where have you found the info you’ve come up with though? Like the offset mounting you have in that thread. I designed and printed a gimbal style mount for mine, that clamps to the side arm of my hex, and keeps it plumb and level…just figuring it should be that way. But if they don’t suggest that I’d want to change it.

Sorry Lance, I’m only an user, not electronic, with a bad experience with Lidar and better with sf11 following instructions, if not usefull, forget my comment; I’m going to take in mind your comment when I migrate to 3.4, thank’s.

Hi Lance,

I have experimented with an SF11 and 3.4-rc1 but I can’t recreate the ‘Bad Lidar Health’ issues you are having. You typically see that message when ArduPilot isn’t getting the required update rate from the lidar. But you shouldn’t have to do anything special for the update rate to be correct, since ArduPilot controls the rate itself.

Can you confirm for me you are getting the bad lidar health message the majority of your flight on 3.4-rc1?

Hi Lance,

Looking through the logs in the zip you posted, they all seem to be from 3.3.3?

Rob…thanks for replying.

Sorry I’m at work atm…but I’ll look into this as soon as I get home.

I’m certain that I flashed 3.4 rc from mission planner - through the beta firmware. I know it was showing on the icon of the model when I clicked it to upload.
I also originally flashed it using the custom firmware option, and the Craft & Theory compiled firmware. So I’m confused…which is nothing new…

Hi Rob,

Re: Can you confirm for me you are getting the bad lidar health message the majority of your flight on 3.4-rc1?

I can’t confirm that as I never launched while using this firmware - because I couldn’t get the fc to see or report readings from it via serial or i2c, which was the original issue.

The reason I had loaded 3.4 was to see if I could get i2c working, so that I could free up the serial port.

I just couldn’t get it to read i2c, and then, when I tried serial…couldn’t get anything off of that.

When I flashed the official, non-craft and theory build, I was able to get serial, but i2c was flaky at best. And still had the non-stop check range finder and bad lidar healt issues etc.

I’ll load it back up when I get home and try it again.

Thanks Rob.

cala no reason for a sorry :slight_smile:

I dislike messaging and txt for that very reason - too easy to misinterpret emotion.

I hope you didn’t think I was being a jerk - not at all my intention.

1 Like

No problem Lance, my is the problem that my english is horrible and time to time I wrote badly, I’m interested in your results using 3.4 because here we have auto sonarrange but I’m waiting devs to solve auto issues to update, (with my sf11 copter)

Ok…I reloaded 3.4 rc (from Mission Planner - beta fw).

Power off - plug sf11 into i2c - power on - connect with mp - change settings for i2c (rngfnd - address = 102 {changed to 0x66 to match your latest manual revision} change rngfind type to 7 (lightware i2c) and turn off serial type 9/lidar.
write settings
power cycle
i2c still not working. gives bad lidar health / check range finder. Can’t get it to read - won’t arm with this error.

Power off. Plug back into serial. Power on [revert the above settings] - write settings.disconnect…power cycle…reconnect
appear no readings - however - no error message.
I forget I need to hold the craft up about 3 ft to get it to set with the optical flow sensor…but it’s being flakey and won’t set. I wind up having to raise it about chest height and point it out almost horizontal, then I get the (i call it) mode change tone, blue led quits blinking and I get reading on the sonarrng. I lift it up and move around with it…the sonarrng and altitude aren’t quit jibing…the altitude tends to wonder while it sits anyway but this is different in that the altitude reading on the hud is different from the sonarrng value.

I hold it up and point it straight out to verify sf11 is reading…fine up to 120’ +. Put back on ground…move to launch point.
Arm…take off…hove in alt-hold for a second and move to pos-hold,. hover for a second and start making progressively larger circles with progressive height. change to loiter mode. Seems to be no error messages yet although my Taranis sounds aren’t setup with this and I have no telem on it…couldn’t full time look at MP to check for errors.

Switch to land…start getting alt.terrain.mismatch (I think is what it was) and that stayed on the hud till I powered off.

I came in to type this up. New logs posted on the link above.

Hope this is helpful…and thanks.

EDIT: Another thing…at some points…it seems the hud altitude (I’m assume baro?) is inverse of what the sonarrng reads.

1 Like

You can get hold of a engineer at Lightware with this email or