Lidar RPLIDAR A2 setup on Pixhawk cube

Hi all,

I would like to ask for help in the assembly and setup of my A2 lidar with a pixhawk 2.1
I have wired the following way to telemetry port 2
The parameters:

  • [SERIAL2_PROTOCOL] = “11”
  • [SERIAL2_BAUD]= “115”
  • [PRX_TYPE]= “5”
  • [PRX_ORIENT]= “0”
  • [BRD_SER2_RTSCTS]= “0”
    But in Mission Planner’s proximity viewer there is no information there

I’m not sure if I did something wrong, do I have to arm before? and put in auto mode?
The lidar has power because the rotor turns perfect

Thank’s for your help


Swap your Tx and Rx over.
A2 Tx to Pixhawk Rx
A2 Rx to Pixhawk Tx

1 Like

You’ve probably already seen it but for other who may read this thread the setup wiki page is here.

Hi rmackay9

Thank’s for your answer but I followed the wiki and the unit did not work, Does this unit could do object avoidance?


It certainly should work so I suspect there are one of a couple of potential problems:

  • a power issue. Perhaps the flight controller is not able to provide enough power to the lidar so a separate BEC is required
  • the lidar being used is not exactly the lidar described on the wiki so it uses a different (perhaps unsupported) protocol
  • some other configuration issue on the AP side like baud rate or protocol hasn’t been done exactly as described on the wiki

Rover’s object avoidance is described on this wiki page. An alternative setup using ROS is also described here.

You say the lidar he is using isn’t exactly the same as the one on the wiki. What is different? They both seem to be the same and I don’t see any model numbers.

Hello sir, I’ve had similar problems with many rplidar a2 units, let me tell you the setup that worked for me (at least to get readings). I used an external 5V BEC to power the lidar (you need to take out the red wire from the cable that connects to the flight controller).
Before flying you need to disconnect the BEC (power off the lidar). Power on the flight controller first and then power on the lidar (I don’t know why but it works half of the time), and eventually your lidar will work… until you notice how sensitive it is to sunlight, maybe you can find a way to block it. I’m not using it ever again, but hopefully you can make it work. Good luck!

Yes Sergio, I did in the same way and works. But is not very usable this solution.

Could be great to put a delay in the software to solve this!

1 Like

Hello, same problem for me, Telem2 no power. but if i connect to Telem1 (which i use for 433Mh) i get power and rplidar a2 start rotating.

1 Like

@rmackay9 does rover object avoidance using ros works on jetson nano?

This power fom Flight Controller can be to weak. It’s better to power external devices like lidar from separate BEC.

have You used Rplidar with pixhawk firmware?

@rmackay9 @Serch

I can second that; I got my A2 working with Ardurover 4.0; however, if the vehicle is powered on at the same time as the lidar, it will not work. I have to reboot the pixhawk after the lidar has been running for a short time, then it will work.

I got same issue, and work as same way, turn on CubeBlack first, then turn on RPlidar.