Servers by jDrones

Lidar Rangefinder for Pixhawk Cube


(Karu2003) #21

We have i2c 1 MHz. :slight_smile: It will be later. :slight_smile: Now we need to decide with Ardupilot Team how to add IO and multiplexer. So far, we’ve done a complete refactoring of the RangeFinder parameters. 64 parameters on all the boards are few. now Ardupilot support already 21 sensor. We have not added one yet. https://github.com/ArduPilot/ardupilot/pull/8816


(ppoirier) #22

Problem is with sensor distance reading time, it is more than 20 msec so if you go sequentially its less than 5 hz for a 10 sensor unit , making avoidance a little marginal


(Karu2003) #23

20 msec is an unavoidable evil. :slight_smile: The rest is solved by tackles and readiness. The conveyor works. :slight_smile: Ardupilot will not wait.


(moonmotor) #24

I had to upgrade to the Beta version of ArduCopter for my liar to work


(ptegler) #25

…bben using the Leddar one units with GREAT success…good for about 40m outdoors


…have a 3D printed case… rock solid altitude hold even crossing various terrain media

ptegler


(Keith) #26

Choppedxs,

I have been trying to get that LIDAR unit to work on the 2.1 since it was released. Like you I have never been able to get it to work, either I2C or Serial. I have bitten the bullet and ordered the LW20/C, hoping it will work, and work well with the IR lock system.

Cheers


(Paul Bealing) #27

Thanks for that note dellphs. Its nice to know its not just me. Hopefully you can let me know how you get on with the new one. I will also check out the Leddarone although I may need better range then 40m. Thanks ptegler.


(Keith) #28

Paul,

I received and installed my new LW20/C. At first I was having the same problem. I went with a serial connection in Telemetry 2 on my Pixhawk 2.1 because I am using the I2C for the IR Lock camera. After fiddling with the setting for several hours I had an Epiphany…The Telem 2 port doesn’t support 11520, which the LW20 is factory set to. So I swapped from Telem 2 to Telem 1 and voila, everything started talking the way it should. I have to wait til next weekend to test fly it, hoping the precision loiter and land work well. Don’t know if this will help your issue, but I thought I would pass the info along.
Cheers!