Lidar Lite V3 and Dropix - how to make it work? (Copter 4.0.5) PWM and I²C does not work

Hi, I am already trying to make my Lidar Lite V3 working for the whole day. Hardware: Dropix V2.1, Firmware: Copter 4.0.5

First I tried via PWM. Connected first like in Wiki and then like in Garmin manual (p.3). With extern BEC and with PWM voltage from Dropix. Voltage is 5.3V

The internal red LED is flashing and the infrared LED was glowing but Ardupilot did not receive any data.

Then I tried via I2C. Also different connections like in Wiki or Garmin manual. With external BEC and without, additional GND to my Dropix and only GND to external BEC. Nothing happens.
Via I2C I do not find a way to make the infrared LED glowing but internal red LED is still flashing.

So first question:
What does make the LED glowing? Only the 1kOhm resitor? (I use two 470Ohm instead) How does it work then via I2C?

Yes, how do I make everything working?


Good day, take care coz the red led its not a let but the laser diode inside.
don’t exceed the 5.0V when powering the sensor.
You have to set few parameters in MP for make it work
Better you use i2c protocol for it

Hello, yes it is a near infrared laser (not an LED, correct). I meant the infrared laser = infrared LED. And then there is a red LED inside the case flashing when powered.

I still do not understand why the near-Infrared laser glows when it is connected via PWM but not when connected via I²C (checked by digital camera) althoug red LED flashes in both cases. Something must activate the laser. I think the 1kOhm resistor? Or what is it? Do I also need to add the resistor when connected via I²C?

About the code:
First when I tried via PWM

Then I changed to (I²C):

Lidar is connected to I2C SDA and SCL of Dropix:
Wiring diagram via I²C (also tried without GND to Dropix)

MP says range finder not detected

Via i2c you don’t need add the resistor… you have only add a capacitor as wiki.

Then I have no idea why the laser is not working and why it is not detected. I just changed the BEC by one that creates exactly 4,9V but still no difference. When should the laser start working when connected via I²C? Directly when powered or later? When i have a resistor between PWM and GND it starts directly after power is connected. When connected without resistor and with capacitor the laser stays off.

What could be the problem?

You set the address for the sensor i2c? just check also that you don’t have another i2c periph that have same add coz there will be a conflict

1 Like

Hm makes sense :smiley:
Which address do I have to set? Never used more than one I2C device before. My other i2C device is my compass, attached to the row below.

Okay after addressing the lidar sensor it works now. I used “49” from this thread because I have no clue what could be a correct value:

Could somebody please add this information to wiki?

This is how it works now on my Dropix. Did not see the reason to add a third BEC because the one on PWM output is only for redundancy so I conntected it there.

I suggest power extra periph you need with an ubec if its required like rangefinders…, rf antennas… etc.
Power the rail of the fc… if supported by the hardware, provide redundancy.
Just consider that too much lite can saturate the reading of the sensors…, when it’s time i suggest you led infrared rangefinders…, low power consumption and fresh rate more fast

1 Like

I considered using IR rangefinders but I think a laser lidar is more suitable in my case. We already talked about this: Which LIDAR sensor for distance measurement?
About powering: I think I still have redundancy when the lidar is connected to the PWM rail of my FC. The BEC can provide 3A but the lidar only needs 0.135A. Or is there something I haven’t considered yet?

Even rail can have a stable voltage, its always better power extra periphs with an extra power source.

1 Like

Thanks for this post - I have been in this spot for a few weeks - do you still operate Lidar Lite v3 with i2c address of 49?

im using teraranger evo 60m sensor… and Lightware lidar