Lidar Lite--Pwm doesn't work either?

I am aware of the I2C failure issues but thought I would be able to get PWM to work…Not so…
I have checked and rechecked wiring, configured parameters as per wiki… Using FW 3.3rc1 on my Pixhawk…
I have nothing but 0 readings on the sonarrng and sonavoltage in status… Do I assume it has to be in ALThold and armed to work?

Exactly the same issue here, I’ve been having it for a couple of months now and have not yet found a solution. I’ve tried arming but still get no readings.

Hi, there might be an error in the wiki since it says:

[code]You then need the following parameters set to enable the PWM driver:

RNGFND_OFFSET = 0[/code]

but RNGFND_TYPE = 5 does not exist, you have to set RNGFND_TYPE=4. Might that be your issue?

I got Lidar Lite working with APM Plane 3.3 beta 1 :slight_smile:

Juanjo, did you get it working in PWM mode? I can get it to work in I2C mode, but like the others I’m not getting any data in PWM on APM:Plane 3.3

Update: I got it working. Four things to check:

  1. You need to have the LiPo/BEC plugged in. (in PWM mode, the LIDAR-Lite gets its power from the servo rail, which is powered by the BEC)
  2. If you’re using a safety switch, this may need to be pushed to arm the vehicle
  3. For some reason APMPlanner doesn’t display the data, but Mission Planner does.
  4. Make sure the LIDAR is not right on a table and is at least 15cm or so from the nearest surface. Otherwise, it will display 0 distance (which is correct!)

@Robert - rngfnd type 5 is correct. See this page. … ngfnd_type

There is a minimum range at which the lidar is accurate. Normally when we are testing we have it on its back pointed at the ceiling as that’s usually over 1m away at least.

zlite - delighted you got it working.

Thanks, Grant.

@gmorph thanks for the clarification, those value details do not appear on Mission Planner (where 4 is the highest value and its description is just “PX4”). That’s why I mistakenly said 5 wasn’t a valid value.


Well, PWM does work… I had to bec power the servo rail first and sonarrange is right on… Thanks for the responses… Now to mount and try it out…

Flight test in ALThold with Lidar lite was perfect using PWM…

zlite, I have not been able to make it work yet, using either PWM or I2C. I have also just checked the four things on your list:

  1. BEC is plugged in and the voltage across the servo rail is 5V.
  2. I’ve pushed the safety switch and armed appropriately.
  3. Using Mission Planner.
  4. LIDAR is facing upward, to the ceiling which is around 3m higher.

Could there be any other thing to check out I might be missing?

Additionally, I tried checking if the LIDAR is actually functional, but using and Arduino and the test code by PulsedLight, it seems to be working perfectly.

Thanks in advance!

Add me to the list of folks who got LidarLite working on my bench.

Now if I can just get it to work in the air!

I read elsewhere that APM 3.3 used Lidar for altitude only in ‘Alt Hold’ and ‘Loiter’. True?

Help me lobby to get it Auto!