Learning Mode NO GPS Coordinates

I’m not sure if I should have, but I just updated my Rover firmware to V3.1.0. After doing so, when I try to learn waypoints with channecl 7, it records points, but they are all at 0 latitute, 0 longitute, and 0 altitude. I tried restarting everything but not change. Any advice or do I need to revert to v3.0. Thanks.

Did you save a copy of your parameters that you could reload after the update before doing the update?
It could be that the update has changed some of your parameters without you knowing it?

I’m having a similar issue. I receive no LAT/LON yet have a 3d_dgps fix and 19 sats detected…but My U-blox is now detected only at 115200…with 3.1.0beta3 it was 38400.

This is in all modes…have reloaded parameters from working config.

I did save the configuration file and that has not worked. I’d appreciate any further help with this. I also have GPS 3d_dgps fix.

Well, I reverted back to Rover Version 3.0.1 and the learning mode will record correct coordinates now, but it will not clear them when toggling channel 7 in manual mode like its supposed to (minor issue). Additionally, I was having major issues getting auto mode to work in conjunction with the sabertooth controller in mixed or linear mode. Once reverting to v3.0.1 I could get it to work in mixed mode (skid steer in and out both disabled). I could also get manual mode to work to work with skid steer out enabled and the sabertooth in linear mode, however, it would not work in auto mode. It would spin the rover to a certain direction and then shake back and forth. I tried adjusting PID’s but to no avail. Anyway, it works decently in mixed mode. Only negative is it I don’t think it can be set to pivot on a dime (PIVOT_TURN_ANGLE - only is active when skid steer out is enabled). Is there any way to work around that? To be able to make it pivot on spot when greater than a certain steering angle is commanded and it is stopped? I hope some of these bugs can be resolved because its pretty irritating trying to figure out which configurations actually work like they’re supposed to. Thanks.

Thanks Nathan. I’ll have a look later this afternoon and let you know what I find.
Note I don’t have a Sabertooth controller so I’m not sure how much I can help you in that regard as I don’t know what magic they do internally.
Thanks, Grant.

Nathan, we have new GPS checks whilst starting up now. Do you have arming checks and arming enabled? I very strongly recommend you do. You will note you can’t arm for a few seconds (about 10) after startup whilst the Rover gets its GPS lock sorted out.

When you say you saved the configuration file and that didn’t work what do you mean? You couldn’t save it from Mission Planner?

If you had a log file you could send (or a link to a dropbox/google drive etc) that would help enormously.

Thanks, Grant.

I’ve just tested in SITL and learning waypoints is working fine for me in 3.1.0. Make sure ARMING_CHECK=1 and ARMING_REQUIRE=1 and CH7_OPTION=1. Turn the rover on and wait until the GPS is happy - you won’t be able to arm until it is. Arm the rover. Go into LEARNING mode. Drive the rover and toggle channel 7. The waypoints should be learned. Let me know how you go.
Thanks, Grant.