Servers by jDrones

Learning mode and ch7 issue


(LarsS) #1

Hello!

I built an arduboat with apm. Modes are man, learn, auto. Ch7 is set to a switch. Radio calibration was succesful. A time ago, the learning option worked well. But now, no waypoints will ba added at learning mode and ch7 toggle.

Btw: I got two boats, learning worked well in the past. But know same issue (no recording) at both boats. Is there an issue with the firmware?? I think i installed the last version. But I don’t know at the moment. To connect via usb means disassembling many parts. So I’m going to ask here 1st.

Thanks for helping!


(LarsS) #2

I got ArduRover v2.50

Does anyone has a solution, please?

In my mind I used v2.47 before, this was working. But I don´t believe, that v2.50 does not support this feature anymore.

Please Help!

Thanks in forward!


(LarsS) #3

I tested several APMrover versions (2.45,2.47,2.50)

I can´t create waypoints! Ch7 switch is working at mode learning (checked at “radio calibration”).

Wtf is going wrong! Can any developer can help me please?

It is the most important feature for my Baitboat. Please give advise!

Thanks

[attachment=2]SC5 scaled1.JPG[/attachment]

[attachment=1]SC5 scaled2.JPG[/attachment]

[attachment=0]SC5 scaled3.JPG[/attachment]


(Thomas J Coyle III) #4

@LarsS,
What is your LEARN_CH parameter value set to?
Regards,
TCIII AVD


(gmorph) #5

Created this issue to investigate.
github.com/diydrones/ardupilot/issues/3036
Thanks, Grant.


(gmorph) #6

I’ve tested this and its working for me. Remember you need to be in LEARNING mode and then toggle channel 7 (or whatever your LEARN_CH is set to) to record the waypoints.
If you still have issues let me know.
Thanks, Grant.


(Thomas J Coyle III) #7

Hi Grant,
The recording of waypoints when in the Learning Mode is also dependent on whether the Learning Toggle switch is being toggled from low to high and back to low or high to low and back to high. I believe the correct sequence is low to high and back to low. It will not work with the other sequence I believe.
Regards,
TCIII AVD


(LarsS) #8

Hi gmorph!

It is certainly learning mode. Ch7 is working fine too at radio calibration. I am using channel 10 at the receiver output and plugged it into channel 7 at the apm. the apm notices the changing frequency very well. But there is no action with record waypoints. TCIII brings me to an consideration: should I enlarge the pwm value from low to high? for now it is about 300hz difference, approx 1300 to 1600. Or should I use ch7 out from the receiver and ch7 in at the apm?

Hopefully someone can give his setup here with his own working rover. I would try to compare with my parameters.

Thank you very much!


(LarsS) #9

I built another boat a few weeks ago by using the miniAPM again. There is no trouble with learning waypoints.

But the other 2 older boats wont do learn wp´s. This drives me crazy… Unfortunately, the new boat is sold and I can´t compare anymore…

By the way: Is there a possibility to load up my config, so a Pro can have a look at my setup? I think that would be best solution!


(LarsS) #10

My Problem is solved! TCIII gave the right direction to investigate the issue! Thank you very much!

The Solution is to enlarge the range from low to high! first it was set up at approx 1300-1600 pwm value. Reversing did not work, too. So I increased the range from 1100 to 1900 pwm and APM is doing what it has to do!

Cheers!


(dksmall) #11

I’m seeing the same problem, but using channel 6 for learning way points, with no success. I wanted to verify that the parameters you changed for channel 7 was RC7_MIN and RC7_MAX. Is that correct?


(LarsS) #12

I changed the pwm space between min and max in my remote control. Then ardurover recognized the changing parameter and set the waypoint by switching the corresponding channel. I don’t know anymore, if a new radio calibration in missionplanner is necessary after changing the pwm in the radio control, but i think so…

Hope, you can fix it now!


(dksmall) #13

Well my radio is already sending a large swing for min/max, so that’s not going to change my setup. I’ll keep digging, thanks!


(LarsS) #14

You also have to assign the right channel number at Parameters. Did you do?


(dksmall) #15

Yes, LEARN_CH = 6 and CH7_OPTION = 0


(LarsS) #16

I suggest to use the ch7 input at the apm.

The channel at your remote doesn’t matter at all…


(dksmall) #17

I looked over the source code and it appears I have to have CH7_OPTION = 1, even though I’m not using CH7 for the learn channel. Will verify tonight.

Oh, and while I was digging I saw that the high threshold for the learning function in hardcoded at 1800. So you changing your upper PWM to 1900 allowed your setup to work, since you were now exceeding the 1800 limit,