Latest missionplanner can't update betafirmware

I have tried several time with no luck.Is there a way to solv the problem?I can’t get copter betafirmware.

Try the two step process - first force bootloader then load firmware

1 Like

Tried severall time nothing.only plane and rover shows up.

try downloading it from the repo (the .apj)

then install with the custom firmware button in the bottom right

There are2 type black cube and blackcube +.Doesit matter wchich one?
There are to type Hex file.

  1. Arducopter.hex
    2 arducopter bl.ex

i would guess you have a normal cube black as i don’t thing the plus’s are out yet. You want the .apj file i think

Thanks I found the right file.The file that is suitable is fmuv3.not blackcube in my case.thanks anyway.

No, that is not correct. Black cubes need black cube firmware. Do not use fmuv3 firmware on any cube:

See here:

You could try asking over at - that’s the official support channel for cube autopilots. However, this topic of fmuv3 vs cube black has been covered multiple times. The answer is do not run fmuv3 firmware on cubes.

It is possible your cube is suffering from a manufacturing defect. ProfiCNC has posted a service bulletin for this defect. When I had a cube that had the defect, mission planner loaded fmuv3 multiple times. There is some detection of this fault built into mission planner, but the detection will only function with the cube black firmware. Once I finally did manage to load the cube black firmware, mission planner detected the defect. If mission planner detects the defect, users are being instructed to contact their reseller where they purchased the cube.

See here for details:

1 Like

You need the Chibios file

The file will end in .APJ

You need CubeBlack firmware