Latest Mission planner display problems again!

We’ve gone back to the irritation display issues with mission planner in the latest build. Cant see many values, no descriptions, lettering tiny. This happened in previous builds but keep comming back in newer. Not many of us still use xvga

this is ultimately a sign of a bad internet connection while MP is updating.
press control-f > paramgen.

Hmm, my internet connection is 100Mbps while opening MP, so the problem might be out there somewhere. When pressing Ctrl-F, I can’t find anything to fix this display problem. Please tell me how to get rid of this.

When You press ctrl+f You should see new window with different settings

Michael suggested to push this “Param gen” button

Ok, I´ll try that. Thanks Nikita.

Hi there! I updated to 1.3.50 yesterday and am experiencing the same display issues referenced above. I tried control-f > paramgen but it didn’t resolve the problem. I’m running Windows 10 on a MS Surface Book at 3000 x 2000 resolution. Until I can fix the display issue, Mission Planner is essentially unusable.

First time posting on this forum. FWIW, I have been using MP for about six months and am incredibly impressed that most of it is the work of one individual. I wouldn’t have thought it possible. Awesome job.

Yes that solution has made zero difference. Find it hard to believe the bad internet connection theory.

Hi, I am still unable to resolve the display issue. Here’s a link to screenshots of the Flight Data and Flight Planner screens: https://1drv.ms/f/s!AgUSon7GqayphWrYZ4-vPd08XPXT

As you can see, text is too small to be readable in some cases, but in others the text overflows boxes. And in other situations, the text is partially obscured or occluded by other objects on the screen.

Prior to the 1.3.50 update, I had not experienced the display issue. Nothing about my screen resolution or scaling has changed in the recent past.

I am running Windows 10 Pro on a Surface Book. Resolution is 3000 x 2000 pixels and 200% scaling. I am also using an external monitor: HP 1920 x 1080 resolution, 100% scaling.

The display problems are present on both monitors and remain on the laptop when I undock it. Graphics card is NVidia GeForce.

I appreciate any help…cuz I really need it!

Seems to be a surface book issue mine is a surface book 3 (or any high dpi screen)

Hi Nathan, just to clarify–you mean Surface Pro 3, correct? I have a Surface Book 2, and I think that’s the highest they go.

Anyway, you might well be right about this issue relating to the Surface family of laptops. In the meantime, I uninstalled 1.3.50 and reverted back to 1.3.49. The display is once again normal. The downside is I’m stuck with the firmware currently on my flight controllers. Okay, I just ran Mission Planner 1.3.49 and connected it to a drone I had already set up. Everything looks normal…good!

Michael, I’m sure you’re a busy person! Could you let us know if this issue is something you’ll be working on?

Thanks.

can you check this
https://support.microsoft.com/en-au/help/3025083/windows-scaling-issues-for-high-dpi-devices

and try
Change application properties
In Explorer or on the Start menu, right-click the application name, select Properties, select the Compatibility tab, and then select the Disable display scaling on high DPI settings check box.

I applied your suggestion and…Success!!

Michael, thanks for helping resolve a problem for what is likely a small segment of overall users. One additional bit of information for anyone else trying to fix this:

on my laptop, when you select the Compatibility tab, the appropriate text reads: “Override high DPI scaling behavior. Scaling performed by:”

At which point you’re offered a drop box with “Application” as the default selection. That selection doesn’t work. Choose System or System (Enhanced) instead.

Thanks again. Sorry to bother you.
Richard

Yes that seems to work.

Note : you’ll need the latest Windows Creators update in order to have the option of Scaling performed by: system
Non creators update just has the standard DPI overide

Actually that doesn’t work. I tried again today but the old display problem still exists. Tried to set up a GPS fence for a flight exam and the pull down selector contents were not viable. Tried through parameters and the descriptions were not visable either.

please post a screenshot, its hard to guess at the issue otherwise

FYI, the fix I implemented on my Surface Book is still working. No display issues.

Hello,

I am having the same problem as Nathaliel_McMahon: I have done the suggestion you said (override high DPI scaling in Compatibility tab) and it seems to display better but not perfect. Letters overlap or they are so small you can not read them well.

what version MP are you running?

Seems cleared up for me. It was doing it with the latest version and now somehow isn’t.

The last version; 1.3.52.2