Servers by jDrones

Latest Beta Build will not load firmware


(kelly) #1

Upgrading to the latest Beta of mission planner will not allow upgrading flight controller firmware (Mission Planner 1.3.56.4 Build 1.3.6746.12212)

When going through the process of powering down the flight controller, clicking on OK in mission planner, then power the flight controller up again (over the USB cable), the latest Beta version does not see the flight controller to do the upgrade.

This is not a hardware issue. Used various USB cables that worked previously and two different flight controllers - Cube and pixraptor. First ran into this on a Windows 7 computer (Intel NUC with external powered USB3 hub - Intel NUC USB ports will not power Cube properly for firmware upgrade) and on my main Windows 10 computer which has always worked,

Was stumped, so tried QGroundControl, and it worked flawlessly. First time I used QGroundControl to load firmware. So this ruled out any hardware issues.

Downloaded Mission planner 1.3.55 (build 1.3.6660.28588) and installed after unloading Beta version of Mission planner. Was able to do firmware upgrades.

Downloaded Mission planner 1.3.56 (build 1.3.6672.30243) and installed on top of 1.3.55, and still able to load firmware.

Installed latest Beta (from Mission planner) so was now at 1.3.56.4 (build 1.3.6746.12212) and no longer able to load firmware.

Ran the install program for 1.3.56 again and selected repair. Version came up as 1.3.56 (no .4 at the end), but the last part of the build number was still 12212 - did not note the rest of the build number. Not able to load firmware to the flight controllers.

Did an uninstall of Mission planner, then install of 1.3.56, and was able to load firmware to the flight controllers again.

So does seem to be an issue with the Beta build.


(Michael Oborne) #2

what autopilot are you trying to upload to?


(kelly) #3

Was trying to upgrade ArduRover from one of the latest 3.3 versions to 3.4.0 or 3.4.1rc-1. I never recorded what the prior version of ArduRover was. Tried different target firmware (Copter, Antenna Tracker), but this did not make a difference.

Even once I had ArduRover 3.4.0 or 3.4.1 rc-1 installed on the flight controllers, had the same issue with the latest Beta version of Mission Planner being unable to see the flight controller during a firmware change after the power cycle and hitting OK so the boot up mode could be seen by Mission Planner.

Again, uninstall of latest Beta version and installing latest release version fixed the problem. This may have worked with a prior Beta version, but who documents this part when it works!


(Michael Oborne) #4

what hardware is what I meant?


(kelly) #5

Two different flight controllers, a Cube and a PixRaptor (copy of PixHawk.)

Have a Hobby King version of the PixHawk that needs a firmware upgrade ready to go and could try against if you think it will help.


(Michael Oborne) #6

I just tested agains a cube, and had no issues

I think there was a bad beta update that duplicated some dll’s and this is actualy casuing the issue

have a look in c:\programdata\missionplanner\missionplanner.log for errors


(kelly) #7

Lots of these error messages:

2018-06-27 15:37:37,296 ERROR MissionPlanner.Utilities.BoardDetect - System.IO.FileLoadException: Could not load file or assembly ‘System.IO.Ports, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'System.IO.Ports, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51’
at px4uploader.Uploader…ctor(String port, Int32 baudrate)
at MissionPlanner.Utilities.BoardDetect.DetectBoard(String port)
Mission Planner_Logs.zip (29.6 KB)

Have zipped up two of the larger log files from yesterday for you to look at.

Hope this helps.

  • Kelly

(Michael Oborne) #8

ok in the mp install dir, there will be 2 px4uploader files, one a dll, one a exe. delete the dll version.


(kelly) #9

Bingo! That fixed the problem. Deleted the file and updated to the latest mission planner beta and was able to do a firmware upload with no problems.

Now to do the other computer. May have to reload the firmware from clean as noticed something did not go quite right when I upgraded the HK Pixhawk copy from ArduRover 3.4.0 rc1 to 3.4.1 rc1 using latest stable mission planner. Not mission planner, something must have gotten hosed with the upgrade of the controller. Put latest Arducopter on, then latest Ardurover 3.4.1 rc1 and the oddities driving me nuts went away. Sometimes best to just start clean!

Thanks, Michael. Good find.

  • Kelly

(Ian Joyce) #10

I’m experiencing the same problem, can you tell me where the mp install directory is located so i can delete the dll file?


(kelly) #11

For me:

C:\Program Files (x86)\Mission Planner