Latest beta (1.3.8096.22330) breaks MP on Windows 11 [solved]

Wanting to update my Copter to the latest 4.2 beta build today, I first updated MP to the latest beta, as is usually best practice. I can no longer connect to any MAVLink serial device (multiple flight controllers and radios attempted). I tried reinstalling drivers, but it’s not a driver problem. MAVProxy connects fine.

Reverting to 1.3.76 stable from the GitHub releases page (1.3.8029.15962) allows for successful connection.

1 Like

Identical behavior here. Revert to stable per the link above for now.

hopefully will be fixed now


Thank you, @Michael_Oborne!

I still have the problem with beta 1.3.8100.8715 and Windows 10.

No matter if via USB or UDP, the heartbeat packets are not recognized.

With older MP versions, the connections are made perfectly.


EDIT: I forgot that you have to do a manual update from the current stable release because of the AppVeyor oddities. A manual update to the beta release results in the same, broken behavior.

ok another fix posted, mavlink was broken

Working now, thank you!

Tthanks a thousand, works again

regarding this error, this one is a odd one, but the manualy fix it
in a text editor
seach for
and rename it to something invalid

save, and try again