Large Quadcopter flips over, but to different directions

I recently finished my quadcopter. It is a big one. 120cm in diameter, about 5kg of weight and it runs 28 inch propellers driven by four Tiger Motor U8-16 100kv motors with a 6 cell LiPo. Im using PixHawk with Arducopter 3.2.1.

It is almost impossible to take off. If I increase the throttle, it tends to flip over instead of lifting itself. Sometimes three legs are above the ground so it rotates in the air around the last leg that remains on the ground, just hovering a few centimeters above the ground but if I increase the throttle further, it starts flipping again.

The strange thing is that it does not flip to the same side every time. One motor is always lacking behind (in terms of rotations per seconds) but it is not the same motor. I could assume that it is always the motor which is located at the most upper part of the terrain (The lawn is not totally flat but it is hard to recognize with the eye). If I just turn the quadcopter so a different motor stands at the position of the formerly slower motor, that motor starts spinning slower as well. So I guess it is not related to ESC calibration error or wrong motor positions.

I have even been able to take off three times (When all motors spun equally) and then the quadcopter behaves not too bad (It drifts a bit but not too much).

So the question is: Why is the quadcopter not adjusting the rotation speed of the slower spinning motor as soon as the other motors lift the quadcopter and the lifter is horizontal again? It seems like the motor keeps the same rotation speed, even if the quadcopter is almost flipping over to the direction of the slower motor.

Because the quadcopter is able to fly in general I assume that motors and ESCs work well. It seems to be just the take off which causes trouble. I use stabelize mode during take off. Also tried HoldPos and Loiter but both with same results.

Does anybody have a clue?

Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

These are the latest log files from mission planner. I have no idea how to interpret these files.

I fixed it. It is difficult to tell what exactly solved it but I assume it is the new version. I formerly used mission planner to flash my Pixhawk to Arducopter 3.2.1.

Now I downloaded the latest version from here:

That version is definitely newer than 3.2.1 (How can I check the version of the firmware? I guess it is a 3.3 beta)
This version also has a new sonar pre-arm check (Which I personally find useful but I had to search the forum until I found out how to arm it with a working sonar! Hint: The sonar seems to wait for a value between 50cm and 2 meters before the pre-arm test is successfully passed)

Now the UAV behaves normal and is very stable.