Large quadcopter flip and crash

I will post logs soon, but, trying to identify the cause of a crash with a new build.

We are using a Foxtech Devourer 130 with 28" props. The first flight was ok, it hovered fine and small movements worked OK. You could tell it needed to be tuned as it was quite sloppy, but, it was flying for about 3 min or so without issue.

The Second flight I put it up and gave it a little more stick input, when I did this it leaned to the right (as I commanded with right aileron) then when it went back to center it went far to the left then back and flipped itself over before crashing into the ground.

I believe the main reason for the crash is high vibrations. The Pixhawk is mounted on the supplied large pads, but, with large propellers it has low frequency vibrations that are probably shaking the pixhawk quite a bit on those pads. I am thinking a more firm mounting solution would be much better for a large quad as the large pads supplied with the pixhawk will probably make the lower frequency larger vibrations even worse than they are.

The other possibility is the stock tuning settings are just way off for a large quad as most people are flying much smaller quads. Could PID settings being way off casue a flip like this, or, is it most likely a vibration issue?

I will post logs soon. This was Arducopter 3.3rc5 (Wanted to use this for the increased sensitivity to vibrations in the latest firmware).

Here are the logs. It doesn’t look like the vibrations are out of tolerance.

Could the crash have just been caused by the tuning parameters being so far off?

The compass variance error shows up, but, I only flew it in stabilize mode so I don’t believe the compass will have any effect. … MU2ba?dl=0

Thank you for any help.

Everything is repaired and I decided to mount the pixhawk on some doublesided tape instead of the foam pads as I have a feeling with these large props and low frequency vibrations it is better to have a more solid mounting surface similar to using a FBL on a heli.

Is it log 2015-06-13 15-17-28? If so, the vibration level seems fine. It’s you mag readings that are really alarming. 3 times the acceptable levels. I’m running the X8 version, but went with 8s as I found the 6s didn
’t have enough power for corrections.

Thanks for the tip, yea vibes didn’t seem to bed except during the crash. We will test more today or tomorrow.

We are in a Quad configuration with KDE Motors on 12s. It hovers around 40% throttle without payload, should be dead on 50 with the payload.

After changing a lot of things, getting vibrations down to normal levels and no more accel clipping, and ensuring ESC’s were set to the proper minimum throttle level. We had the same problem again today.

I am completely clueless as to what the issue could be.

Any help or suggestions would be greatly appreciated.

Here’s the logs from today. … %3A2055691 … %3A2055692

Are you using the KDE7215 motors? It would be great to get it flying good enough to try an autotune.

KDE 7208’s.

But, we can’t seem to not have it flip and crash. The logs point to an issue with ESC’s or motors. Seems like they can’t respond fast enough.

110kv on 12s should have plenty of response time with 28" props.

PWM is set properly and a simlar ground for both BEC’s powering the pixhawk.

I presume you’re using KDE esc’s? Sounds like a sync issue. Strap your rig down…really well : ) Go to motor test in Mission Planner and start each motor from 70, 80, 90 and 100%. If there’s sync issue you’ll see stalling.

Excellent, that’s the plan today. Yes, KDE ESC’s.

On low throttle one of the ESC’s takes a bit to get spinning. It jerks the motor a bit. but I thinkt hat is normal as once it is spinning it is smooth. I only tested to 20% so far without strapping the quad down. I’ll strap it down now and test more at higher throttle.

So just look for the motor to stop spinning?

Thank you for this! Definetly an ESC Synch issue. I didn’t thnk there would be issues with KDE Motors and ESC’s combined, but, there sure is. Really bad issues on 12s.

When doing the motor test, you’ll enter the % of throttle. Basically it will be from 0 to what you entered. From 80-100% you’re looking for the motor to start stuttering instead of a smooth acceleration.

Oops, posted this before I read your last post. Nothing more frustrating than dinging up a big (expensive) unit like yours. Surprising they don’t work together. I’ve had motors that it didn’t matter what esc or firmware, they just stalled! In particular the Foxtech 6135’s, junk.

Hi @Jman841 , I am also running KDE motors and ESC’s. I ended up having to set up the TX itself to use the 1100-1900us range in the RC calibration screen, every other solution seemed like a patch and seemed to lead to spotty results. I had a strange crash that may or may not be related to this setup; I can’t say yet since I haven’t yet finished repairs to try again. I do know my first few flights in Stabilize then in Loiter were generally just fine, and only muddied by my challenges setting min/max and midpoint for throttle.

What do you think will be your next steps? How can it be that these “matched” motors and ESC’s of very high quality cannot work? Are we missing something, or is it a limitation of Pixhawk that I don’t fully understand yet?

Or have you determined one of your ESC’s/motors are defective, thereby causing the sync issue? Patrick at KDE is very responsive and helpful in case you weren’t already aware.

You could setup current limiting on your pixhawk as a temporary fix. It would prevent the motors from going full on and stalling. Correction response of course is going to be slower, but better than crashing. Can’t remember what parameter it is, but I’m sure it’s only available in 3.3 beta.

The param is mot_curr_max. But that’s total current so it won’t work. That wasn’t much help. Call KDE and let us know. I was going to try a 7215X8, but I’d like to know the customer service is good : )

Thanks for the tips guys.

Tomorrow I am going to run one more test using just a Futaba Rx to ensure it is not a pixhawk issue. I have sent an email to patrick and his customer service is excellent.

The only reason I am very hesitatnt to blame the pixhawk is, the sync issue does not happen on 6s.

Today I tested 12s, 11s, 10s, and 6s. 10s-12s all had the same problem. I uploaded a video below.

6s worked well, although one motor has a lot harder time starting and runs at a lower RPM for some odd reason, but, I suspect that is a separate issue.

It is quite disappointing after reading all about how the KDE ESC’s are optimized for their motors. But, a very high pole count motor on 12s is most certainly not an easy motor to drive smoothly.

I will let you know tomorrow after I verify that it is not the pixhawk. But again, I don’t see how it would work fine on 6s if it was the pixhawk. I think it’s just the communication of the motor on higher voltage is too high for the ESC.

This video is only 50% throttle.

I am working with Patrick from KDE to resolve this. He mentioned he has not seen this before so we will hopefully find out the problem soon.

Definetly an ESC issue. Tested with a Futaba Rx and have the same problems.

Here’s a slow spool up then fast throttle changes. Slow spool up works fine, sync issues are on fast throttle changes.

Working with patrick to resolve this. This is not a dig on KDE products as their products are excellent. Hopefully have it resolved soon.

Did you resolve the issue with Patrick? I’m setting up a larger X8 with 7215’s and the new 95a esc’s on 8s. I wanted to know before jumping into a new can of worms lol.

You should be good to go. The latest firmware is much, much better on these large motors.

The issue is not totally resolved as I think the 7208’s just don’t have enough torque for the props were using to be run on 12s. We are either going to lower the prop, lower the voltage, or switch to the 7215’s. Have not decided yet.

But, you can buy with confidence that the 95hv ESC’s with the 7215’s will work well.