Large quad EKF3 lane switch

I am testing a large (28" prop, ~15Kg) quad. I have everything mostly working, but during most flights I’ll get several EKF3 lane switch messages. It usually (but not always) seems to occur during moments of higher vibration. There seem to be no ill effects around the time of the switch, but I would like to know what is going on. I have also seen this message on other platforms.

https://drive.google.com/file/d/1-0NSN-Y7gNm4aCEwxNmmKSO437mTnXRT/view?usp=sharing

You are still on ArduCopter V4.2.0-rc3 , best to update that to latest stable.

There’s slightly excessive Z axis vibrations showing via the non-damped IMU. Probably best to try and tame those Z vibes somewhat. There’s no clipping and it’s not affecting the damped IMUs.

There is some lane switches which appear to be related to differences in altitude between the two baro’s and the GPS Alt. Maybe it is due to prop wash over the baro’s??

There’s lots of
No ap_message for mavlink id (xxxx)
which I cant find the meaning of, maybe the firmware upgrade will fix it.

Apart from those, I’d try to improve the tuning somewhat, attitude control

I think your ATC_RAT_PIT_D could be up to 0.007, maybe try 0.005 first
and ATC_RAT_RLL_D could also come up to about 0.005, maybe try 0.003 first
Launch and hover for just a minute or less, land and check motor temperatures. If stability is worse just put them back of course.

Also your MOT_THST_EXPO could possibly go up to about 0.79 and this might help with the stability, but you might have to experiment a little:

  • set too high you can see instability at low throttle
  • set too low you can see instability at high throttle

Depending on which ESCs you have it might even be better at 0.5

INS_ACCEL_FILTER,10 is quite low, I would tend to keep it at default 20 and try to reduce vibrations. Maybe try to keep it above 15 anyway.

I would adjust your harmonic notch filter as follows:
INS_HNTCH_REF,0.39
INS_HNTCH_FREQ,45
INS_HNTCH_BW,22

After these changes it would be best to Autotune again if possible.
It would be good to see another .bin log if you can make improvements.

Thanks for the thorough reply. I’ll give your suggestions a try.

MOT_THST_EXPO was calculated using thrust stand data. See here:

This aircraft does suffer from instability at low throttle, so maybe I should try lowering the EXPO. I’m using t-motor alpha ESCs.

Could you explain your rationale on the INS_HNTCH settings?

Which Motor thrust stand was used?
Is this a T-Motor P80-X set with Alpha 80A HV ESCs and MF3016 props?

It was that motor combo but with a rigid 30" prop from Mejzlik.

It was one of these thrust stands:

The HNOTCH settings might not be perfect but should be close enough, it was an educated guess based on estimated motor RPM, and the fact that there’s an obvious large harmonic still visible at around 90Hz to 100Hz. A log with pre-filter data would be good.

INS_HNTCH_REF was calculated by MOT_THST_HOVER x 0.8 which is usually close enough.
The real formula is
INS_HNTCH_REF = hover_thrust * SQUAREROOT(min_freq / hover_freq)

Also I was thinking, do the firmware upgrade then retest to see if this copter is sensitive to the position. This shows up in Loiter (hovering) as instability or oscillations, switch to AltHold and the craft is steady. The position controller is chasing tiny variations in reported GPS position to the point of building up oscillations.
If you have that issue, halve the value of
PSC_VELXY_D
and if it’s still an issue, halve these too
PSC_POSXY_P
PSC_VELXY_I
PSC_VELXY_P
Do the firmware upgrade first though and see if that’s even an issue for you.

I’ve done a little more testing.

I have not updated the firmware as this requires merging in a bunch of our patches so is not trivial. I believe the AP_message thing has to do with some telemetry stream being requested from qgroundcontrol. I did dig into it once and came to the conclusion that it was just a nuisance.

I upped the D gains as recommended, and I think this helped, but was not dramatic. I upped the INS_ACCEL_FILTER to 15, not sure if these had any effect.

I did not change the INS_HNTCH settings as I thought I should first provide a set of log files with no payload as well.

Log files: All from today, really windy, 30-40kph.

167.BIN - no payload, easy grid flight. Some EKF lanes switches, but not too often.
https://drive.google.com/file/d/11y2tehl2oSHxVPr5jalJUAfvq-DTFuBQ/view?usp=sharing

169.BIN - no payload, INS_LOG_BAT_OPT=2
https://drive.google.com/file/d/1jOxhzeFNA0Ih37TIAqfcT37QmyDR2phy/view?usp=sharing

170.BIN - 10Kg payload, grid flight. very frequent lane switches. Noticed some wandering up and down on altitude as well.
https://drive.google.com/file/d/1YfTeyGAu5oz9OqNFABHjwx7qX2bTk0E9/view?usp=sharing

171.BIN - 10Kg payload, INS_LOG_BAT_OPT=2. some gently motion, but still had many lane switches
https://drive.google.com/file/d/1apJLcEmhs3dsrxdtogPn1gwptyBXgM7N/view?usp=sharing

172.BIN - 10Kg payload, taped over some vents in the aircraft fuselage to try to rule out baro issues. This had no effect.
https://drive.google.com/file/d/10MCQl4nsqeMgTC35OpECDqGcySXNXr2b/view?usp=sharing

Can I try to get to the underlying cause by disabling certain sensors? It seems to be flying really well except for the barrage of EKF messages. This aircraft is a “H” configuration with large tube for the fuselage. I have observed at high air speeds that the fuselage can pull slight a vacuum.

Please provide your thoughts.